WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

#6291 closed defect (bug) (fixed)

widget bug: disappearing widget

Reported by: Denis-de-Bernardy Owned by:
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

insert a new widget who can have several versions of itself into a sidebar. ex: a text widget.

move it around in the sidebar (not sure this is even necessary)

click edit, to edit the widget

click cancel, to cancel the changes

save changes

the widget is gone...

Attachments (1)

6291.diff (3.6 KB) - added by mdawaffe 12 years ago.

Download all attachments as: .zip

Change History (11)

#1 @lloydbudd
12 years ago

  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid. Please include information including subversion revision and the browser you used.

#2 @lloydbudd
12 years ago

  • Keywords needsinfo added

#3 @mtekk
12 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

lloydbudd, I reproduced this in r7396. I achieved this using the following steps:

1) Added a text widget.
2) Modified the widget and committed it's change.
3) Added the recent comments widget and saved the sidebar again.
4) Added a second text widget, moved it from the default bottom to between the first text widget and the comments widget.
5) Clicked the Edit button, didn't change anything, then clicked the Cancel button.
6) Saved the sidebar.

After doing this the new (blank) text widget disappears. After further investigation all that was needed is a previous instance of the multi instance widget and clicking the Edit and then Cancel button, if the Edit and then Cancel button are not pressed the widget is still there when you save.

I guess this could be a discrepancy in the desired behavior here. I'd have it if you don't edit the text widget, thus leaving it blank, to have it removed when saving. However that isn't what always happens, and thus could be confusing. Though, I can see the utility of having it keep everything you dump in the sidebar unless you tell it to remove it.

#4 follow-up: @mtekk
12 years ago

Additionally, this bug is present in Firefox 2.x. In IE8 and IE8 in IE7 emulation mode clicking the edit button makes it instantly disappear. I wouldn't worry about the behavior in IE8 as I'm seeing more regressions, standards wise, in it hopefully the final version of it is better. In IE6, I observe the same problem as IE8 and IE8 in IE7 emulation mode.

#5 in reply to: ↑ 4 ; follow-up: @mdawaffe
12 years ago

6291.diff

Multi-widgets should never be removed if you click cancel.

Replying to mtekk:

In IE8 and IE8 in IE7 emulation mode clicking the edit button makes it instantly disappear.

I don't understand what you're saying. Do you mean that clicking edit makes the widget go away entirely? Or do you mean that the animation is instantaneous rather than smooth? This sounds like an unrelated issue and should have its own ticket.

FYI: The animation was intentionally made smooth in IE see ticket:5997:3.

@mdawaffe
12 years ago

#6 @mdawaffe
12 years ago

  • Keywords has-patch commit added

#7 @mdawaffe
12 years ago

I meant

FYI: The animation was intentionally made instantaneous in IE see ticket:5997:3.

#8 in reply to: ↑ 5 @mtekk
12 years ago

Replying to mdawaffe:

I don't understand what you're saying. Do you mean that clicking edit makes the widget go away entirely? Or do you mean that the animation is instantaneous rather than smooth? This sounds like an unrelated issue and should have its own ticket.

FYI: The animation was intentionally made smooth in IE see ticket:5997:3.

In any version of IE (6, 7, and 8 beta) when you click edit, the text widget totally disappears, as if you told it to delete that widget from your sidebar. I have IE8 beta and experienced this in both IE8 "normal mode" and IE7 "emulation mode". On an XP machine in IE6 the same thing happened. It seems to be really a different bug from what this one is but was discovered while testing for this one.

#9 @lloydbudd
12 years ago

  • Keywords needsinfo removed
  • Milestone set to 2.5

#10 @markjaquith
12 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [7411]) Multi-widgets should never be removed if you click cancel. props mdawaffe. fixes #6291

Note: See TracTickets for help on using tickets.