WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#6320 closed defect (bug) (invalid)

Post's Author Problem

Reported by: link2caro Owned by:
Milestone: Priority: high
Severity: major Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Sometimes when I view a post of other user, the author change automatically to be me, so the original author of the post loses the right to edit (if that author has a lower level)

Change History (8)

comment:1 @link2caro7 years ago

Btw, if an username has a space, the URL for that author seems not to work.

http://www.techinfovn.com/author/CA RO/ => 404 page

comment:2 in reply to: ↑ description @ffemtcj7 years ago

Replying to link2caro:

Sometimes when I view a post of other user, the author change automatically to be me, so the original author of the post loses the right to edit (if that author has a lower level)

How exactly did you do this so I can try to reproduce?

comment:3 @ffemtcj7 years ago

Also, is this using 2.5 RC1 or another version?

comment:4 @link2caro7 years ago

ENV 2.5-RC1.1

I did not do anything, or I clicked Save, that is the last thing I could think of.

comment:5 @link2caro7 years ago

It's probably due to the autosave function I believe.

comment:6 follow-up: @link2caro7 years ago

New bug, /author/username/ returns posts of other authors that were edited by the requested author

Please check it out.

comment:7 in reply to: ↑ 6 @link2caro7 years ago

Replying to link2caro:

New bug, /author/username/ returns posts of other authors that were edited by the requested author

Please check it out.

Sorry theme issue! Resolved

comment:8 @ryan7 years ago

  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Resolving as invalid based on original reporter feedback.

Note: See TracTickets for help on using tickets.