WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6388 closed defect (bug) (worksforme)

"Settings saved." yellow box flashes irregularly in FF2

Reported by: Viper007Bond Owned by:
Milestone: Priority: low
Severity: trivial Version: 2.5
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

In Firefox 2 under Windows XP, when I hit "Save Changes" on say Options -> General, the yellow box that pops up at the top of the page flashes between a brighter yellow and the background color as it fades out.

Simply put, the fading isn't working right.

Attachments (2)

6388.diff (1.4 KB) - added by caesarsgrunt 12 years ago.
6388.2.diff (1.3 KB) - added by caesarsgrunt 12 years ago.

Download all attachments as: .zip

Change History (14)

#1 follow-up: @DD32
12 years ago

Looks like its supposed to pulse like that.. The colours however arnt different enough for me to notice it until you mentioned it :)

http://trac.wordpress.org/browser/trunk/wp-admin/js/common.js#L3

#2 in reply to: ↑ 1 @Viper007Bond
12 years ago

Replying to DD32:

Looks like its supposed to pulse like that..

Oh, I was thinking it was a bug since it goes "flash flash... flash... flash flash flash..." etc. for me -- i.e. it's not smooth.

Looks like crap honestly since it's not doing it regularly, and is semi-annoying in general.

#3 @Viper007Bond
12 years ago

  • Summary changed from "Settings saved." yellow box flashes in FF2 to "Settings saved." yellow box flashes irregularly in FF2

#4 @DD32
12 years ago

Looks like crap honestly since it's not doing it regularly, and is semi-annoying in general.

Its pretty regular in Opera, and in FF2 when i tested it(I hadnt noticed it pulsed myself), For me on a CRT the colour change isnt very obvious at all, nor does it catch attention. It might look better on a TFT.

Until you mentioned it, I hadnt noticed that it had stopped fading the messages out.

#5 @DD32
12 years ago

Which page are you testing it on? Are there any other onload javascript's firing on that page?

I'm thinking something might be interupting the animation loop and its adding a small delay.

#6 @Viper007Bond
12 years ago

I'm just going directly to /wp-admin/options-general.php?updated=true in my browser.

It's a combination fade/flash now rather than just a fade which I think may be the problem (the two effects causing issues with each other?).

Oh and yes, I have a LCD, but I can see it on my 2nd monitor (a CRT) as well. It's rather obvious, at least for me, on both and is like a really fast (albeit small) strobe light.

#7 @caesarsgrunt
12 years ago

Hadn't notice, but now that I have it irritates me as is.
Here's a patch.

@caesarsgrunt
12 years ago

#8 @caesarsgrunt
12 years ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from 2.9 to 2.7

@caesarsgrunt
12 years ago

#9 @caesarsgrunt
12 years ago

  • Cc caesarsgrunt added
  • Keywords dev-feedback added

This second patch might be nicer actually - slower, less irritating fade/pulse, and only once.

#10 @caesarsgrunt
12 years ago

  • Keywords commit added; dev-feedback removed

Commit, if people like it...

#11 @matt
12 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

This is intended behaviour, but may change with 2.7 design. Not in the way this ticket recommends though, so closing as it's not really related.

#12 @thee17
12 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.