WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 2 weeks ago

#6393 closed enhancement (wontfix)

Export & import blogroll with categories

Reported by: jayminkapish Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Import Keywords: needs-patch
Focuses: Cc:

Description

I have attached a patch which will export Blogroll OPML file having a category attribute in it. It is valid to have a category attribute in outline tag. Generated OPML file by wp-links-opml.php has been validated by http://validator.opml.org/.

I have also updated link-import.php and link-parse-opml.php files in wp-admin to parse category attribute and create link_category in database if it does not exist and assign link to that category.

This enhancement will automatically export and import link-categories with links.

Attachments (2)

wp_export_import_links.patch (3.2 KB) - added by jayminkapish 11 years ago.
WP Export - Import Blogroll with categories patch
wp_export_import_links_with_cats_new.patch (4.0 KB) - added by jayminkapish 11 years ago.
export import blogroll with categories, description and targets

Download all attachments as: .zip

Change History (12)

@jayminkapish
11 years ago

WP Export - Import Blogroll with categories patch

#1 @jayminkapish
11 years ago

  • Keywords has patch export-import blogroll added

I forgot to add description and target in OPML file. So exporter exports description and target as well. Importer imports description right now but does not import targets.

attached a new patch.

@jayminkapish
11 years ago

export import blogroll with categories, description and targets

#2 @westi
10 years ago

  • Milestone changed from 2.7 to 2.8

Nice idea but 2.7 is feature frozen now moving to 2.8

#3 @DD32
10 years ago

  • Component changed from General to Import
  • Owner anonymous deleted

#4 @janeforshort
10 years ago

  • Milestone changed from 2.8 to Future Release

Punting to be evaluated in next development cycle due to time constraints.

#5 @Denis-de-Bernardy
10 years ago

  • Keywords needs added; has removed

#6 @Denis-de-Bernardy
10 years ago

  • Keywords needs-patch added; needs patch removed

#7 @Ipstenu
8 years ago

Is this still being looked at?

I know I can export my links by going to http://YOURBLOGSADDRESS/wp-links-opml.php and viewing source, but there should be a GUI for this too. After all, we have Blogroll IMPORT on the import tab. :)

#8 @SergeyBiryukov
6 years ago

Closed #21615 as a duplicate.

#9 @chriscct7
3 years ago

  • Keywords export-import blogroll removed

#10 @iseulde
2 weeks ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This ticket has not seen any activity in over *two* years, so I'm closing it as "wontfix".

The ticket may lack decisiveness, may have become irrelevant, or may not have gathered enough interest.

If you think this ticket does deserve some attention again, feel free to reopen.

For bugs, it would be great if you could provide updated steps to reproduce against the latest version of WordPress (5.0.2 at the time of writing). Remember images or a video can be superior to explain a problem. At the very least, quickly test again to make sure the bug still exists.

If it’s an enhancement or feature, some extra motivation may help.

Thank you for your contributions to WordPress! <3

Note: See TracTickets for help on using tickets.