WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#6416 closed defect (bug) (duplicate)

Cannot edit page-slug before publishing

Reported by: link2caro Owned by:
Milestone: Priority: high
Severity: normal Version: 2.6.1
Component: Administration Keywords: permalink
Focuses: Cc:

Description

When compose a post, it's possible to edit the post-slug but in the mode for page, it cannot be edited before publishing.

Attachments (1)

wp.JPG (76.6 KB) - added by link2caro 6 years ago.
Screenshot

Download all attachments as: .zip

Change History (15)

comment:1 MichaelH6 years ago

At 2.5RC2 (R7548) I'm not having that problem.

Are you using a pretty permalink such as Month and name?

You need to complete a Title for the Page before the permalink edit option is offered.

comment:2 lloydbudd6 years ago

  • Keywords need-info added
  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version set to 2.5

comment:3 link2caro6 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I entered the Title already but nothing changed, I compared with the post-new already

ENV 2.5

Permenant URL Structure
/%year%/%monthnum%/%day%/%hour%%minute%%second%%post_id%/

but I am wondering, this structure is used for Post only, not Page?

comment:4 link2caro6 years ago

  • Version changed from 2.5 to 2.5.1

comment:5 link2caro6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 Viper007Bond6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Viper007Bond6 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:8 Viper007Bond6 years ago

Pages aren't posts. You should read up on the differences.

http://codex.wordpress.org/Pages

link2caro6 years ago

Screenshot

comment:9 link2caro6 years ago

I still have the problem on one of my website in fact, server 1and1.fr

Sorry for the l10n, but the yellow line shows that the page is saved, and the status panel shows the time of last save.

Another website, on another server with the same l10n and plugins, I do not have this problem. BTW, I am aware of the different between Page and Post.

ENV 2.5

comment:10 nbachiyski6 years ago

Do you have pretty permalinks option enabled?

comment:11 link2caro6 years ago

If the question was for me, YES, I have three sites and I am sure sure sure that they have the same configurations.

comment:12 link2caro6 years ago

Another ticket for the same issue: 6529

comment:13 in reply to: ↑ description Jonno996 years ago

  • Keywords permalink added; need-info removed
  • Resolution invalid deleted
  • Severity changed from major to normal
  • Status changed from closed to reopened
  • Version changed from 2.5.1 to 2.6.1

Replying to link2caro:

When compose a post, it's possible to edit the post-slug but in the mode for page, it cannot be edited before publishing.

I am having the same issue with pages (only, posts are fine) in 2.6.1. When you save a page, the edit permalink does not show up. It only shows after the post is published, which it's the best time to edit a permalink.

Yes, I have fancy permalinks /%postname%/ turned on.

comment:14 nbachiyski6 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #6529.

Note: See TracTickets for help on using tickets.