WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

#6435 closed defect (bug) (worksforme)

Updating custom fields disables the "Save" and "Publish" buttons

Reported by: fitztrev Owned by:
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.6.1
Component: Administration Keywords:
Focuses: Cc:

Description

After successfully changing a post's meta value, both the "Save" and "Publish" buttons appear to be returning false. Clicking them does nothing.

To recreate:
1) Edit a preexisting post that has some custom field values
2) Change the meta value
3) Click "Update"
4) Try and save or publish

Change History (8)

comment:1 @markjaquith7 years ago

Cannot reproduce on [7563]. Try different browsers, computers, etc, and see if you can narrow it down.

comment:2 @fitztrev7 years ago

I just tried again on r7565 and the issue persists. Unfortunately (or fortunately?), I only have one OS and browser -- Ubuntu and FireFox -- so I cannot easily try other setups.

comment:3 @markjaquith7 years ago

  • Milestone changed from 2.5 to 2.5.1
  • Version set to 2.5

Can you try Firefox in safe mode (disables Add-Ons)? Also, which version of Firefox?

comment:4 @fitztrev7 years ago

I tried again on the Ubuntu 8.04 (Hardy Heron) Beta live cd with Firefox 3.0b4, and the same thing happened. I made no changes to the Firefox configuration and no add-ons were present.

I've tried digging around some more to see what could be going wrong, but can't figure it out.

comment:5 @ryan7 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

comment:6 @The_Tim7 years ago

  • Version changed from 2.5 to 2.6.1

I can confirm that I have been experiencing the same problem in Windows XP with Firefox 3.0.1 as well as Internet Explorer 7.0.5730.13.

Steps to reproduce:

1) Create a post with a dummy headline and body, click "Save."
2) Add a custom field with any values for 'key' and 'value.'
3) Save the post again.
4) Edit the 'value' for the custom field to something different and click "Update."
5) Now clicking "Save" on the post does nothing.

I have noticed that if you add another custom field or delete a custom field the "Save" button starts working again.

Hope that helps someone figure this out. It's really annoying, especially in conjunction with the recently-introduced bug that adds extraneous backslashes to custom fields.

comment:7 @Denis-de-Bernardy6 years ago

  • Component changed from General to Administration

comment:8 @scribu5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce in trunk, Ubuntu 9.10, Firefox 3.5. Reopen if problem persists.

Note: See TracTickets for help on using tickets.