WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6460 closed defect (bug) (fixed)

Feed PHP files show no posts when WP has it's own directory

Reported by: Viper007Bond Owned by: westi
Milestone: 2.6 Priority: highest omg bbq
Severity: critical Version: 2.5
Component: General Keywords: has-patch
Focuses: Cc:

Description

I have all plugins disabled on my personal blog, but wp-rss2.php and it's siblings are all displaying no posts. They aren't blank, just no posts to display.

However, the pretty URLs work just fine (I've disabled my FeedBurner mod_rewrite redirect rules for the moment).

Works: http://www.viper007bond.com/feed/
Nope: http://www.viper007bond.com/wordpress/wp-rss2.php

Works: http://www.viper007bond.com/feed/atom/
Nope: http://www.viper007bond.com/wordpress/wp-atom.php

The exact same thing is happening on another WordPress install on the same server too:

http://www.finalgear.com/wordpress/wp-rss2.php

It still has active plugins though.

phpinfo(): http://www.viper007bond.com/phpinfo.php
MySQL 5.0.45

Attachments (1)

6460.diff (1.3 KB) - added by DD32 6 years ago.

Download all attachments as: .zip

Change History (27)

comment:1 Viper007Bond6 years ago

  • Keywords needs-patch added
  • Summary changed from All feed PHP files return no posts, pretty URLs do to Feed PHP files are blank when WP has it's own directory

Okay, I got how to duplicate it! If siteurl != homeurl, it breaks, i.e. if WordPress is in it's own directory.

I made a nice and fresh new WordPress install and both /feed/ and /wp-rss2.php worked fine. Then I moved the WordPress files and /feed/ worked while /subdirectory/wp-rss2.php did not.

As to why this is happening is beyond me. I don't know the feed code well enough.

comment:2 DD326 years ago

Yup, Confirmed it with my blog having a HomeURL != SiteURL

http://dd32.id.au/wordpress/wp-rss2.php - doesnt work
http://dd32.id.au/feed/ - works

comment:3 Viper007Bond6 years ago

  • Summary changed from Feed PHP files are blank when WP has it's own directory to Feed PHP files show no posts when WP has it's own directory

comment:4 westi6 years ago

  • Owner changed from anonymous to westi
  • Status changed from new to assigned

Does this exist in 2.3.3 ?

If so it may relate to [4551]

comment:5 Viper007Bond6 years ago

No, it worked fine in 2.3.3.

comment:6 westi6 years ago

Ok. It seems to work fine in my local test with permalinks disabled.
Now to try with them enabled.

comment:7 westi6 years ago

Definitely doesn't work with permalinks enabled.

It matches as a page lookup instead.

I have a fix which I will land in trunk for now and get some feedback/review before back porting to 2.5.1

comment:8 westi6 years ago

(In [7574]) Make sure the rewrite rules for the feed files match when WordPress is installed in a subdirectory. See #6460 this is for trunk.

comment:9 lloydbudd6 years ago

  • Keywords has-patch added; needs-patch removed

comment:10 follow-up: markjaquith6 years ago

It fixes the bug for me.

comment:11 in reply to: ↑ 10 westi6 years ago

Replying to markjaquith:

It fixes the bug for me.

Cool. I'll merge this into branches/2.5 for 2.5.1

comment:12 westi6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7583]) Make sure the rewrite rules for the feed files match when WordPress is installed in a subdirectory. Fixes #6460 for 2.5.1.

comment:13 jsherk6 years ago

I would like to try this patch and see if it fixes #6484

Where is the patch? What files were modified/changed?

I tried to figure it out, but don't know my way around trac well enough yet.
Thanks

comment:14 Nazgul6 years ago

There is no patch attached to this ticket. Westi made a patch and commited it directly, without adding it to trac.

But if you click on the [7583] there is a link at the bottom called "Unified Diff".

comment:15 jsherk6 years ago

Okay thanks Nazgul. Tried it on #6484 but has no effect.

comment:16 DD326 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

[7583] has broken HomeURL == SiteURL, See [wp-testers] Feeds not publishing on 2.5.1

The issue is that the slash is not present when WP is installed in the current directory, I'll attach a patch, the Db version will need to be bumped. (Patch against trunk)

DD326 years ago

comment:17 DD326 years ago

[7583] has broken HomeURL == SiteURL

By that, I mean:
HomeURL == SiteURL:

  • /feed/ = works
  • /?feed=rss2 = works
  • /wp-rss2.php = doesnt work.

comment:18 westi6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [7841]) Make sure the direct feed files work when siteurl == homeurl. Fixes #6460 for trunk props DD32.

comment:19 westi6 years ago

  • Milestone changed from 2.5.1 to 2.5.2
  • Resolution fixed deleted
  • Status changed from closed to reopened

Re-open for 2.5.2

comment:20 westi6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [7843]) Make sure the direct feed files work when siteurl == homeurl. Fixes #6460 for the 2.5 branch props DD32.

comment:21 MattyRob6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I've applies the latest changes to my rewrite.php and version.php files and direct access to files such as wp-atom.php still fails to produce output.

HomeURL == SiteURL

  • /feed/ = works
  • /?feed=rss2 = works
  • /wp-rss2.php = doesnt work.

comment:22 DD326 years ago

I've applies the latest changes

Have you accessed the admin page to cause a database upgrade page to come up?

D

comment:23 MattyRob6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

@DD32,

My apologies, I had run the upgrade on one of my site having edited the files but I was looking at the feeds from a different side - full on ID10T issue.

comment:24 ryan6 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

comment:25 scribu6 years ago

  • Milestone 2.9 deleted

comment:26 westi6 years ago

  • Milestone set to 2.6
Note: See TracTickets for help on using tickets.