WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#6466 closed defect (bug) (invalid)

Changing Blog Address URL makes it looked like you've logged out

Reported by: MichaelH Owned by:
Milestone: Priority: normal
Severity: trivial Version: 2.5
Component: Administration Keywords:
Focuses: Cc:

Description

Doing new 2.5 install "with WordPress in its own directory" after changing the General Setting->Blog Address (URL), when you immediately Visit Site, it assumes you are NOT logged in for comments, and the meta section of the blog shows Log in, not Log out.

To duplicate:

  1. Upload wordpress folder into web-root folder. Setup database and wp-config.php
  1. Put index.php in web-root folder that has require('./wordpress/wp-blog-header.php');
  1. Browse to sample.com/wordpress and complete install.
  1. Login and in General->Settings->Blog Address (URL) delete the /wordpress from end of that field.
  1. Click on Visit Site and it will show Log in, not Log out, in the meta section of the sidebar. Also assumes you are NOT logged in for comments.

Change History (3)

comment:1 @ryan7 years ago

  • Milestone changed from 2.7 to 2.8

comment:2 @mrmist7 years ago

Is this not the expected behaviour, since you've changed the URL that the cookie relates to?

comment:3 @MichaelH7 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Severity changed from normal to trivial
  • Status changed from new to closed

I suppose that is expected behaviour in view of the cookies you mention--it changed from 2.3 to 2.5.

Now at 2.7, if you change the Blog Addess (URL), save the changes, then visit site it does show Log in under the Meta section but if you click your browser back button, you are allowed to still do things in the admin section, meaning you aren't really logged out, right? A minor thing...

I'll mark as invalid.

Note: See TracTickets for help on using tickets.