WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 10 years ago

#6470 closed defect (bug) (invalid)

Internet Explorer: Text widget get removed when click on "Edit"

Reported by: terabyten Owned by:
Milestone: Priority: high
Severity: major Version: 2.7
Component: Widgets Keywords: multi-widget, widgets needs-patch
Focuses: Cc:

Description

In IE7:

Text widget under Design>Widgets get removed when click on "Edit" instead of expanding for text to be filled in.

This only happens when the text in the widget is empty and never filled, and the widget page has not been saved with the text-widget at least once! So if you add the widget and then push "edit", it is removed instead of expended to be filled in.

If text-widget is added and you puch "Save Changes", the widget can be filled in without any problem after that.

Change History (16)

#1 @terabyten
11 years ago

  • Severity changed from normal to major

#2 @terabyten
11 years ago

  • Priority changed from normal to high

#3 @mtekk
11 years ago

This seems similar to #6291. Confirmed to be a problem for IE7 and IE8 beta. Looks like a Javascript issue.

#4 @mtekk
11 years ago

  • Summary changed from IE7: Text widget get removed when click on "Edit" to Internet Explorer: Text widget get removed when click on "Edit"

I'm able to reproduce this in IE6,7 and 8 beta, so it's a general Internet Explorer issue.

#5 @jamescollins
11 years ago

I can also reproduce this problem in IE6.

#6 @ryan
11 years ago

  • Owner changed from anonymous to mdawaffe

#8 @mdawaffe
11 years ago

  • Keywords multi-widget widgets added; text widget widget removed

This is in general true for all multiwidgets (RSS, Categories...).

I have no idea what's going on here. I can tell you what's happening, but not why.

When you click the "Edit" link, the edit.click action is fired (good), then the save.click action is fired (bad), then the remove.click action is fired (bad).

Internet explorer is applying the click bindings on source:/trunk/wp-admin/js/widgets.js@7628#L98 and source:/trunk/wp-admin/js/widgets.js@7628#L104 to a.widget-control-edit rather than a.widget-control-save and a.widget-control-remove, respectively.

I have tried and failed to correct this. Anyone care to step in?

#9 follow-up: @Denis-de-Bernardy
11 years ago

there are occasional bugs in jQuery. For instance remove() and replaceWith() do not work as documented in IE. Any odds you tried using bind() instead of the overloaded click(fn) function?

http://docs.jquery.com/Events/bind#typedatafn

D.

#10 @luckyblog
11 years ago

Using IE7

In 2.5, it was possible to get around the problem by

  1. Add the txt widget
  2. Save changes on the sidebar
  3. _Then_ edit the txt widget

(As described by the original reporter of the bug).

Now, in 2.5.1, the problem remains, but the getaround doesn't?
Add widget then hit edit: straight away it dissapears from list.
Add widget, then save changes, then hit edit: still dissappears.
Hit edit on the last widget of the list (whether recently added or not): It dissapears.
Hit edit on any other widget on the list (not the very bottom one): It "shimmers" and then does nothing.

Good luck, looks like a hard bug. I'm gonna try firefox now.

#11 in reply to: ↑ 9 @mdawaffe
11 years ago

  • Keywords needs-patch added
  • Owner mdawaffe deleted

Replying to Denis-de-Bernardy:

Any odds you tried using bind() instead of the overloaded click(fn) function?

Just tried. Didn't work.

#12 @ryan
11 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

#13 @mrmist
10 years ago

  • Milestone changed from 2.9 to 2.7.1
  • Version changed from 2.5 to 2.7

Still current.

#14 @ryan
10 years ago

  • Component changed from Administration to Widgets
  • Milestone changed from 2.7.1 to 2.8

#16 @azaozz
10 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

No longer valid. Now widgets are added by dragging.

Note: See TracTickets for help on using tickets.