WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6486 closed defect (bug) (invalid)

WP 2.5 - Can not insert link (or image) using WYSIWIG editor

Reported by: jpxwordpress Owned by:
Milestone: Priority: normal
Severity: major Version: 2.5
Component: TinyMCE Keywords: insert link problem wysiwig 2.5
Focuses: Cc:

Description

I am unable to 'Insert a Link' in WP 2.5's WYSIWIG editor window. I can not get anything to appear at all in the pop-up window after I highlight some text and try to 'INSERT A LINK' while preparing a post. The same thing also happens if I try to 'INSERT AN IMAGE' using the WYSIWIG - I get nothing but the spinning hourglass/progress bar....

[The browser I am using is Mozilla Firefox 2.0.0.13]

Thank you very much for any feedback you can provide me with to help correct this.

Kevin Pajak – Webmaster, jpopexpress.com

My site’s WordPress Blog:
http://www.jpopexpress.com/blog/

Change History (6)

comment:1 in reply to: ↑ description jpxwordpress6 years ago

Is this the fix I need?

http://trac.wordpress.org/attachment/ticket/6443/fileuploaderfix.patch

Thank you very much for your help.

comment:2 follow-up: azaozz6 years ago

This is usually a caching problem. It has been discussed in the support forums too. The pop-ups in TinyMCE are iframes that need to download the html, js and css files from the server when opened.

Most likely the old files are being used from a cache (either browser's or proxy/network), so it fails. If you have Firebug, check to see what is being downloaded when opening the popups and if some of the files are missing (red 404s in the "Net" tab).

comment:3 in reply to: ↑ 2 jpxwordpress6 years ago

  • Priority changed from highest omg bbq to normal
  • Resolution set to fixed
  • Severity changed from critical to major
  • Status changed from new to closed

Thanks a lot for your advice azaozz, but actually I downloaded the Mozilla Firefox 3 Beta 4 browser and it took care of this issue (someone else in the forum mentioned this, as well the fact also that the issue could have been caused by this caching matter). I am now able to insert links, images, and embed media with teh 2.5 WYSIWIG editor (I should get Firebug too, thanks for that suggestion). Go WordPress.

comment:4 Nazgul6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Nazgul6 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:6 Nazgul6 years ago

  • Milestone 2.5.1 deleted
Note: See TracTickets for help on using tickets.