Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6491 closed defect (bug) (duplicate)

Multiple links categories yields invalid XHTML in links widget

Reported by: jrbirge Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.1
Component: General Keywords:
Focuses: Cc:


If you have multiple links categories, there will be multiple <li>'s created with the same "id=links", which causes the page to fail XHTML validation.

Change History (4)

#1 follow-up: @jrbirge
8 years ago

For what it's worth (I'm not very familiar with WP development) I think this can be fixed quite easily by removing one line from widgets.php:

--- widgets.php (revision 7580)
+++ widgets.php (working copy)
@@ -430,7 +430,6 @@

extract($args, EXTR_SKIP);

'title_before' => $before_title, 'title_after' => $after_title,

  • 'category_before' => $before_widget, 'category_after' => $after_widget,

'show_images' => true, 'class' => 'linkcat widget'



#2 in reply to: ↑ 1 @jrbirge
8 years ago

Ok, that's actually quite a bad fix, for reasons I probably don't need to explain to anybody here. I guess the fix will have to go into bookmark-template.php? When it generates multiple categories, it should append something to the id passed to it so that the id's are unique.

#3 @Otto42
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of ticket #4287.

#4 @lloydbudd
8 years ago

  • Milestone 2.6 deleted
Note: See TracTickets for help on using tickets.