WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#6494 closed defect (bug) (duplicate)

Post Permalink collides with SubPage

Reported by: neoxx Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: permalink, pages
Focuses: Cc:

Description

hi folks!

after playin' several hours with my 2.5 upgrade (from 2.3) i figured out the following issue: say, we got a page with several subpages. these subpages are named 2005, 2006, ... moreover, the permalink structure for the posts is set as 'year/month/day/name'. given that, in 2.3 a static page 'page/2005/' loads perfectly, but in 2.5 is seems like the priority of the permalinks has changed. hence, it breaks this structure.

i had that issue on my page, e.g. my publications of 2008. the workaround is to manually set up any redirection in the htaccess file, to rename the subpages or to set up a different permalink structure...

berny

Change History (3)

comment:1 lloydbudd6 years ago

  • Milestone changed from 2.5.1 to 2.7
  • Priority changed from high to normal

Unusual scenario, pushing out.

comment:2 neoxx6 years ago

  • Milestone changed from 2.7 to 2.6

i disagree. - firstly, i know a couple of weblogs, which use the year as subpage-slug. secondly, it is a bug and no enhancement, because it worked from 2.0 or at least 2.0 up to 2.3.3. hence, it should be at least fixed in the next major release.

comment:3 DD325 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #5305 (permalinks broken when article name is numeric)

Note: See TracTickets for help on using tickets.