WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#6500 closed defect (bug) (duplicate)

Calendar widget is broken

Reported by: Denis-de-Bernardy Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords:
Focuses: Cc:

Description

default theme, all plugins disabled. upon adding the calendar widget, I get:

%BEG_OF_TITLE% %END_OF_TITLE%
Calendar     Edit

... and nothing happens when I click Edit.

After saving the sidebar, the options are available, but it still looks odd.

Change History (7)

comment:1 DD326 years ago

Related: #6442

comment:2 Denis-de-Bernardy6 years ago

My fixed (and modified) calendar widget, for reference, in case it helps to fix the underlying issue:

function widget_calendar($args)
{
	extract($args);
	echo $before_widget;
	if ( !is_admin() )
	{
		echo '<div id="calendar_wrap">';
		get_calendar();
		echo '</div>';
	}
	echo $after_widget;
} # widget_calendar()

The get_calendar() function was causing the issue apparently.

comment:3 ryan6 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

comment:4 mrmist5 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

worksforme in 2.7

Re-open with steps if still reproducable.

comment:5 Denis-de-Bernardy5 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Added a screenshot in #6500

comment:6 Denis-de-Bernardy5 years ago

  • Version changed from 2.5 to 2.7

comment:7 mrmist5 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Ok may as well deal with it in #6442 though, as the issue is the same, bar the mention of a plugin in #6442.

Note: See TracTickets for help on using tickets.