WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#6502 closed defect (bug) (worksforme)

Media uploader error in IE7

Reported by: duncanmc Owned by: andy
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords:
Focuses: Cc:

Description

When I use media uploader for sending images, I am getting object not found errors in IE7. I can not insert images or gallery.

Steps to produce

1) Click on Add an Image button

Image uploader form appers, but IE7 gives Object expected error at media-upload.php file. Error is at the script

<!--
jQuery(function($){

var preloaded = $(".media-item.preloaded");
if ( preloaded.length > 0 ) {

preloaded.each(function(){prepareMediaItem({id:this.id.replace(/[^0-9]/g, )},);});

}
updateMediaForm();

});

Error line is

updateMediaForm();

If I ignore the message and upload a file, the image previews do not show. Also I can not click on Show button and I can not save or insert image.

I tried after clearing browser cache, but it does not work. I tried Firefox and saw that Firefox is working perfectly fine. The problem is only at IE7.

I am using WampServer based on php and apache latest versions.

Change History (11)

comment:1 Otto426 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #6443

comment:2 duncanmc6 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

It is not a dupe of #6443 . I applied the fix for #6443, but I still get the same problem. They are not related.

comment:3 duncanmc6 years ago

  • Summary changed from Media uplaoder error in IE7 to Media uploader error in IE7

comment:4 sdbelt6 years ago

I too am experiencing the exact same error with IE7. With Firefox I do not experience the error.

comment:5 Denis-de-Bernardy6 years ago

+1 on a friend's IE setup.

comment:6 Alphawolf6 years ago

  • Component changed from TinyMCE to Administration

Exactly same issue here on both of my IE7s (Vista 32Bit SP1 + XP 32Bit SP2).

(Changed Component property from TinyMCE to Administration since this doesnt occure with TinyMCE only. Experienced the same issue with deactivated TinyMCE.)

comment:7 ryan6 years ago

  • Owner changed from anonymous to andy
  • Status changed from reopened to new

comment:8 gebintit6 years ago

I am not an expert, but perhaps this problem is similar to a problem some people had on some platforms with WP2.5.1 when they tried to insert media (no problems with the upload). Only a white box appeared. This was (in my case) also linked with an object-not-found error-message with IE7. I found a fix for that problem in a german forum. It's a change in the file /wp-admin/js/media-upload.js . Here is the code (the old values are commented out):

/* var win = window.opener ? window.opener : window.dialogArguments; if ( !win ) win = top; */ var win = parent;

To be honest, I don't know why this patch helped to fix my problem, but now it works!
Perhaps this is also a solution for this ticket?

comment:9 ryan6 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

comment:10 mrmist6 years ago

Probably a similar error to #7310 and fixable in a similar way.

comment:11 mrmist5 years ago

  • Milestone 2.9 deleted
  • Priority changed from high to normal
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Is this still a live issue with 2.7? I've tested the uploader on a few different setups windows and linux and it works. Closing as worksforme.

Note: See TracTickets for help on using tickets.