WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#6520 closed defect (bug) (fixed)

Permalink preview not using time zone

Reported by: Viper007Bond Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

I just wrote a post on my blog and after deselecting the title field, the permalink that popped up was site.com/2008/04/01/post-title/. This is because it was using my server's time rather than the offset I had configured. After I published the post, it was correct.

(It's still March 31st for me.)

See also: #6489

Attachments (1)

6520-post.php.diff (559 bytes) - added by janbrasna 5 years ago.
Patch fixing #6520

Download all attachments as: .zip

Change History (5)

comment:1 janbrasna5 years ago

  • Cc janbrasna added
  • Keywords has-patch added; needs-patch removed
  • Milestone changed from 2.9 to 2.7
  • Summary changed from After autosave, permalink isn't using correct time to Permalink preview not using time zone

janbrasna5 years ago

Patch fixing #6520

comment:2 jacobsantos5 years ago

  • Keywords commit added

Whatever. Patch looks good to me.

comment:3 ryan5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [10007]) No need to fake post_date for drafts anymore. fixes #6520

comment:4 ryan5 years ago

post_date is now set for drafts, so we can remove that line.

Note: See TracTickets for help on using tickets.