WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6548 closed defect (bug) (invalid)

Non-UNIX Lineending in wp-config-sample.php

Reported by: hakre Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: General Keywords:
Focuses: Cc:

Description

In contraire to all the other files I've seen so far in the source, wp-config-sample.php is the only one with PC lineendings (that is \r\n instead of \n).

For more Infos see:
DOS vs. Unix Line Endings
http://www.cs.toronto.edu/~krueger/csc209h/tut/line-endings.html

Solution:
Change the line ending and update in CVS.

Note:
Translators have this problems as well, in the german version taken from "wordpress-deutschland.org" this is the case as well and they even changed the encoding from UTF-8 to ANSI.

Change History (3)

comment:1 @westi7 years ago

  • Milestone 2.5.1 deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is by design.

wp-config-sample.php has PC line endings because it is most often editing by end users on a Windows pc with notepad before uploading to the server using UNIX lineendings would break the good user-experience this creates.

comment:2 follow-up: @hakre7 years ago

And many Windows FTP clients convert it while uploading. Good point.

Are the same kind of thoughts the source for the ANSI encoding in the gemran translation of this file?

comment:3 in reply to: ↑ 2 @lloydbudd7 years ago

Replying to hakre:

Are the same kind of thoughts the source for the ANSI encoding in the gemran translation of this file?

That would be a question for the German team: http://codex.wordpress.org/WordPress_Localization#German_-_Deutsch_.28de_DE.29

Note: See TracTickets for help on using tickets.