WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#6556 closed enhancement (duplicate)

Impossible to move text/rss widgets between sidebars

Reported by: bryan868 Owned by:
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.5
Component: Widgets Keywords: needs-patch
Focuses: Cc:

Description

I'm guessing this isn't much of a defect, but here's hoping! From 2.3 to 2.5 we lost the ability to move existing Text or RSS widgets from one sidebar to another.

If you "remove" the widget from one sidebar it does not move to the unused widgets column, because of the way multiple widget instances was implemented. Thus when you navigate to another sidebar and add a Text/RSS widget, it's fresh and clean. No data is carried over!

Attachments (3)

sidebar_arrange.php (11.4 KB) - added by bryan868 7 years ago.
Sidebar Arrangement Page
widgets.css (7.0 KB) - added by bryan868 7 years ago.
Additional CSS added to existing file
widgets-rtl.css (1.7 KB) - added by bryan868 7 years ago.
Additional CSS added to existing file

Download all attachments as: .zip

Change History (23)

comment:1 @Viper007Bond7 years ago

  • Component changed from General to Administration
  • Keywords needs-patch added
  • Priority changed from normal to lowest
  • Severity changed from normal to minor
  • Type changed from defect to enhancement
  • Version set to 2.5

This isn't a bug really. When you click on "Add", it spawns a new instance of the widget. When you click "Remove", it deletes that instance of the widget.

To do exactly what you're suggesting would require persistent widget instances, i.e. duplicates on the left side, something that was purposely removed from 2.5.

However, a feature could be created to move widgets directly from one sidebar to another, so I'm retagging this as an enhancement.

comment:2 @Viper007Bond7 years ago

  • Milestone changed from 2.6 to 2.7

comment:4 follow-up: @bryan8687 years ago

Viper- While this may not be a bug, it seems like a rather MAJOR design flaw. All other widgets can be moved from one sidebar to another. But you can't move an existing text/rss widget without it being stripped of its data. Can't the data be saved somewhere when an existing text/rss widget is removed from a sidebar?

I hope this can be resolved MUCH BEFORE 2.7.

comment:5 in reply to: ↑ 4 @Viper007Bond7 years ago

Only single instance widgets can retain their data because there's no unique ID tied to them. Multiple instance widgets, like the text and RSS ones, get a unique ID and storing that data after it's removed would do no good. How would you select that old widget to add it back to the other sidebar? You'd have to have duplicates on the left side and that's be a major step backwards.

A much better solution would be a way for widgets to be directly moved from one sidebar to another -- no removing/adding involved.

As for 2.7, that's just what milestone tickets are set to if they have no code or solution attached. If someone writes up code (you're welcome to BTW), it'll be bumped down to 2.6 or possibly 2.5.1. ;)

comment:6 follow-up: @michaelpark7 years ago

In previous versions, I was able to use multiple text widgets without putting them on the sidebar; rather, I called them manually from various locations of my theme which was very handy. Now I have to put those contents statically.

In my opinion, this is a regression and not a progression. After all, WordPress is all about creating dynamic pages.

comment:7 in reply to: ↑ 6 ; follow-up: @Viper007Bond7 years ago

Replying to michaelpark:

I called them manually from various locations of my theme which was very handy. Now I have to put those contents statically.

Just make those sidebars...

In my opinion, this is a regression and not a progression. After all, WordPress is all about creating dynamic pages.

While the new method has it's drawbacks (that we can fix), it's 100x better IMO, especially from a coder's standpoint.

comment:8 in reply to: ↑ 7 @michaelpark7 years ago

Replying to Viper007Bond:

Just make those sidebars...

A small section of the contents area? I don't think so...

comment:9 follow-up: @codeispoetry7 years ago

it's 100x better IMO, especially from a coder's standpoint.

I think it is not an exaggeration to say that one of the reasons of the immense success of WordPress has been exactly that its UI didn't generally reflect the coder's standpoint, but rather that of the user. (Code should be poetry, but there is no reason to sacrifice intuitive user interfaces for that.)

comment:10 in reply to: ↑ 9 ; follow-up: @Viper007Bond7 years ago

Replying to codeispoetry:

(Code should be poetry, but there is no reason to sacrifice intuitive user interfaces for that.)

Which is why I'm fully for allowing easy moving of widgets from one sidebar to another.

I was merely saying that this new widget manager is a huge step forward, albeit an imperfect one, and we shouldn't give up on it so easily and go back to the old multiple instances of widgets on the left hand side (which was rather crude).

comment:11 @bryan8687 years ago

What was so crude about it? So you had 'X' definable number of Text/RSS widgets, but it promoted individuality in widget instances. Plus with the new code you lose essential functions like moving from one sidebar to another. I mean come on, that's standard stuff that no longer works!

comment:12 @Viper007Bond7 years ago

The code was rather crude behind the scenes, plus you had to refresh the page to add more / remove widget instances. The definable number also was a hard cap on the number of widget instances you could have. You can now have 100 text widgets if you want, something you couldn't do in the old versions.

But as I said before, being able to move widgets directly from one sidebar to another would be a very handy feature, one I fully support.

@bryan8687 years ago

Sidebar Arrangement Page

@bryan8687 years ago

Additional CSS added to existing file

@bryan8687 years ago

Additional CSS added to existing file

comment:13 @bryan8687 years ago

  • Milestone changed from 2.7 to 2.6

Added a "Sidebar Arrangement" page, which is essentially the drag and drop functionality from 2.3. This can be a separate sub-page under "Design," or even "Widgets."

Just upload file to /wp-admin/. The necessary CSS for this page was added to the widgets.css and widgets-rtl.css files.

I'm NOT SURE how to create a new link for this new sub-page on the admin navigation.

comment:14 @Jairus7 years ago

Great work, bryan868. The lack of drag-drop was a showstopper for my clients to upgrade.

comment:15 @bryan8687 years ago

  • Milestone changed from 2.9 to 2.7

comment:16 in reply to: ↑ 10 @Otto427 years ago

  • Priority changed from lowest to normal
  • Severity changed from minor to normal

Replying to Viper007Bond:

I was merely saying that this new widget manager is a huge step forward, albeit an imperfect one, and we shouldn't give up on it so easily and go back to the old multiple instances of widgets on the left hand side (which was rather crude).

I cannot believe anybody ever said this.

The 2.5+ widget manager is about the worst possible interface I could ever imagine for such a thing. The original one was a thousand million billion times better, because it was intuitive. You see a widget, you drag it where you want, wham blam, it's done. Hit save. No problem.

The current widget manager has a bewildering array of contradictory options, and is the most unintuitive thing I've ever seen. I've had to teach *programmers* how to use the thing.

No, I'm sorry, but in no sense whatsoever is the new widget manager "good". It never has been, it never will be. Regressing back to the old *code* would be an upgrade, but what we really need is to regress back to the old INTERFACE. Just the interface.

Widgets should be dragged from where they are and dropped to where you want them to be. That's easy. That makes sense. The editability of widgets in-place is fine and dandy, but everything else about the current widget manager sucks rocks.

comment:17 @bryan8687 years ago

I agree 100%, Otto42. I hope this issue gets some attention. Crazyhorse brings a brand new admin interface, but in no way affects the widget admin (which needs the most help).

comment:18 @bryan8686 years ago

  • Milestone changed from 2.7 to 2.8

Jane Wells stated here, that a widget admin overhaul will happen for 2.8.

comment:19 @ryan6 years ago

  • Component changed from Administration to Widgets
  • Owner anonymous deleted

comment:20 @Denis-de-Bernardy6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

closing as dup of #9511

Note: See TracTickets for help on using tickets.