WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6563 closed defect (bug) (duplicate)

"Draft was saved" timestamp does not reflect user's timezone settings

Reported by: ketsugi Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords:
Focuses: Cc:

Description

The "draft saved at" timestamp on the Create New Post page is currently inaccurate, showing server time instead of reflecting the current user's timezone settings, without indicating which timezone is being used for the timestamp.

This timestamp should be be adjusted to match the current user's timezone setting, or at least indicate which timezone it's using to avoid user confusion.

See attached screenshots for example of the problem.

Attachments (2)

draft-saved.png (14.4 KB) - added by ketsugi 6 years ago.
The "draft saved at" timestamp showing the wrong time
timezone.png (4.5 KB) - added by ketsugi 6 years ago.
My timezone settings relating to the previous screenshot

Download all attachments as: .zip

Change History (7)

ketsugi6 years ago

The "draft saved at" timestamp showing the wrong time

ketsugi6 years ago

My timezone settings relating to the previous screenshot

comment:1 ketsugi6 years ago

  • Version set to 2.5

comment:2 markjaquith6 years ago

Hm, it's accurate for me (-05 GMT). For you, screenshots indicate 3pm was GMT, and you're set to +08 GMT... and it shows 9pm (+06 GMT)? Is that an accurate assessment?

comment:3 ketsugi6 years ago

Not quite.

GMT is 3:50am. My timezone is GMT+8, ie 11:50am. The time shown for the draft is 9.46pm (screen shot was taken at 4min difference), which is GMT-6, which I think is CDT, and I assume this is the time that my American webhost's server is set to.

comment:4 Viper007Bond6 years ago

  • Milestone 2.5.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe: #6563

See also: #6520

comment:5 Viper007Bond6 years ago

Mmm, sorry, bad copy/paste. This is a dupe of #6489

Note: See TracTickets for help on using tickets.