WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#6576 closed defect (bug) (duplicate)

Media Uploader problems on a password protected site

Reported by: marky Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Upload Keywords: media uploader
Focuses: Cc:

Description

I password protect my wp-admin directory using standard HTTP auth for an added level of security. I love the new media uploader included with Wordpress 2.5, but it seems to fail for the first upload in each browser session, possibly because of this password protection.

Here's how the problem manifests itself:

When I select a file with the new media uploader, a small dialog appears, prompting me for the username and password. I enter this information and press OK. Everything appears to have worked normally, but the file will not have been successfully uploaded. That is, Wordpress will behave as if it had worked (showing a blank image in the media browser, along with the relevant title and description information), however, the actual image file will not be there.

The solution right now is to do delete the half-created media entry, and upload the media a second time, now that the username and password had been previously entered. This will work for all subsequent uploads, but only for that browser session. The above will have to be repeated for each new browser session.

Change History (4)

comment:1 lloydbudd6 years ago

This sounds like a duplicate of #6473

comment:2 ryan5 years ago

  • Component changed from General to Upload
  • Owner anonymous deleted

comment:3 DD325 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

definately looks like a duplicate of #6473 to me, And is a known issue with the flash uploader AFAIK.

comment:4 thee175 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.