WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6577 closed defect (bug) (fixed)

Custom header and color picker broken in Safari

Reported by: mdawaffe Owned by: ryan
Milestone: 2.5.1 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: has-patch commit
Focuses: Cc:

Description

#3622 was closed as invalid, but it is core code that provides the custom header and color picker functionality.

The problem seems to be caused by some JS conflict between the color picker and the image cropper. Loading them each only when needed resolves the issue.

Additionally, the "use original color" button is broken on all browsers. Attached includes simple fix.

Attachments (1)

6577.diff (5.0 KB) - added by mdawaffe 10 years ago.

Download all attachments as: .zip

Change History (5)

@mdawaffe
10 years ago

#1 @mdawaffe
10 years ago

  • Owner changed from anonymous to mdawaffe
  • Status changed from new to assigned

Attached is tested in FF, Safari3, Opera9, IE6/7

#2 @ryan
10 years ago

  • Owner changed from mdawaffe to ryan
  • Status changed from assigned to new

#3 @ryan
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7697]) Custom header and color picker fixes from mdawaffe. fixes #6577 for 2.5

#4 @ryan
10 years ago

(In [7698]) Custom header and color picker fixes from mdawaffe. fixes #6577 for trunk

Note: See TracTickets for help on using tickets.