WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#6635 closed enhancement (duplicate)

Move categories & tags back to the Write Post/Page sidebar for efficiency & usability

Reported by: sillybean Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords: admin, edit, sidebar, write page
Focuses: Cc:

Description

In 2.3x, there was a logical division between the post's content (things you type on the left) and its meta data (things you select on the right). In 2.5, categories and tags -- things that authors have to touch on every post -- have moved into the content section and are more difficult to access because of the excessive scrolling required.

Since there's plenty of whitespace to the right of the textarea, we propose moving categories and tags back to the sidebar.

See this forum thread for more details. The attached patch comes from ericr23's modification of edit-form-advanced.php, linked on p2 of that discussion.

Attachments (1)

edit.diff (14.4 KB) - added by sillybean 7 years ago.
Revision of edit-form-advanced.php

Download all attachments as: .zip

Change History (6)

@sillybean7 years ago

Revision of edit-form-advanced.php

comment:1 @lelion7 years ago

  • Keywords sidebar write page added

I'd like to add a couple of my thoughts on the subject here:

I am totally 'for' bringing back most of the stuff, which was put down the page in the WRITE section of WordPress, back to the sidebar (not only 'categories'). The current position of the panels 'tags', 'categories', etc., requires much more scrolling up and down the page, when preparing a new post.

'Write a New Post': panels, which can safely go to the sidebar:
'Tags', 'Categories', 'Comments & Pings', 'Password Protect this Post'.

'Write a New page': panels, which can safely go to the sidebar:
'Page Parent', 'Page Template', 'Page Order', 'Comments & Pings', 'Password Protect this Page'.

'Write a New Link': panels, which can safely go to the sidebar:
'Categories', 'Target'.

I believe that moving these to the sidebar will increase the usability of the 'Write' section! It's much more easier to write a post/page, when title & text is on the left, and most of the related meta info for the post/page (categories, tags, page parent, etc.) is on the right side. Also, today's screens become more and more wider (but not as much taller), so using this space in the sidebar is wise! :-)

Also, a lot of users are accustomed to work this way in WordPress, and now it's impossible for them, because even if we can write a plugin, which may change to some extent the look of the Admin interface (via CSS), still, it is practically impossible to bring to the sidebar these panels, without changing some of the core WP files, and this is not a good idea!

I know that at a later stage there are also plans to allow drag-n-drop of these panels again (as in version 2.3.3), so I won't file this here, for now :)

Thanks:)

comment:2 follow-up: @cyndin7 years ago

Some of the changes to this page are excellent (love that WP remembers which areas you open and change and which ones you leave shut and on the default) but I agree that catagories should be back to the sidebar. I don't actually mind the scrolling, but when it was on the sidebar it had more space. Now I only have 6 lines showing in the box, which is a pain when you have dozens of categories.

comment:3 in reply to: ↑ 2 @jabecker7 years ago

Please see http://trac.wordpress.org/ticket/6709, which incorporates this and other usability enhancements.

comment:4 @cyndin7 years ago

Thanks, jabecker. But I haven't the faintest idea what to do with those files. I know how to edit themes, as I can get right into the code from the dashboard. But I can't alter WP code from there. I could do it from emacs on my unix shell where WP is installed, but the files are all in a particular format with line numbers. I can't cut and paste that.

I suppose I am meant to download the files to my computer and then upload them to the WP directory (not sure where they go exactly). But do I need to upload all of them? Do they work together or are they separate? Do I edit the old files or just outright replace them? And won't this mean I can't upgrade WP again? My ISP's upgrader barfs if I so much as download the latest version of a plugin...even if I get it to work, will I lose all my changes and have to do it again in a week or two when 2.5.1 comes out?

I'm not a coder or a developer. I'm pretty knowledgable about computers and web design but have never worked with php and css before (they are newer than when I learned this stuff).

I appreciate that you have taken the time to write and upload these changes, but I don't know where to go from here.

comment:5 @matt7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6709

Note: See TracTickets for help on using tickets.