WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6639 closed defect (bug) (fixed)

Cannot edit comment time and date

Reported by: lelion Owned by:
Milestone: 2.5.1 Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords: comments, time, date
Focuses: Cc:

Description

I have just upgraded from 2.3.3 to 2.5 on a couple of blogs, and noticed a strange thing:

I cannot edit anymore the time a comment is published. Has anyone noticed similar behaviour in WP management of comments?

Steps to reproduce:

Try to edit comment's time. SAVE comment, check again - time is the same as before!

What is even more strange: if you try to edit comment's time AND date, you can! But if you try to edit comment's time ONLY, you cannot!

I am curious to see if only I am observing this strange behaviour when editing comments, or it's a global bug, which affects other users, too.

Note: If needed, can provide you with more info about PHP, MySQL, etc.

Change History (4)

comment:1 lelion6 years ago

OK, a bit of update: actually, you can edit the HOUR, but NOT the minutes. If you edit the hour AND the minutes, the time of the comment IS updated. If you try to edit ONLY the minutes, the time is NOT updated. I observed this on changing a post's time of publishing, too (but I guess, it needs a separate ticket to be filed). Didn't check Page's time, yet. Maybe it's a global problem (cannot edit ONLY minutes of a post/page/comment published time?). Will appreciate if someone else can share his observations in regard to this strange bug...

comment:2 ionfish6 years ago

Are you using the latest version of trunk? It's working fine for me.

comment:3 follow-up: ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I think this is fixed by the changes done for #6456. Marking this one as resolved instead of a duplicate since it describes symptoms for comments instead of posts.

comment:4 in reply to: ↑ 3 lelion6 years ago

Replying to ryan:

I think this is fixed by the changes done for #6456. Marking this one as resolved instead of a duplicate since it describes symptoms for comments instead of posts.

I am using WP 2.5 Stable. Glad that that was already spotted and fixed for 2.5.1.

Cheers! :-)

Note: See TracTickets for help on using tickets.