WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#6661 closed defect (bug) (fixed)

IE6 overlap renders uploader media library unusable

Reported by: tellyworth Owned by:
Milestone: 2.5.1 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: has-patch
Focuses: Cc:

Description

The toggle sliders on the media library tab of the media uploader overlap and render the UI unusable.

Screenshot attached.

Attachments (3)

ie6-overlap.gif (37.7 KB) - added by tellyworth 6 years ago.
media-library-ie6-overlap-r7638.patch (974 bytes) - added by tellyworth 6 years ago.
media-library-ie6-overlap-r7641-2.patch (5.1 KB) - added by tellyworth 6 years ago.
Fix the progress bar, remove some unnecessary markup

Download all attachments as: .zip

Change History (10)

tellyworth6 years ago

comment:1 tellyworth6 years ago

The problem seems to stem from the use of relative and absolute positioning within the tables - it affects the height of containers in unexpected ways, especially with buggy browsers.

I was unable to come up with a fix that retained the same positioning methods, but switching to floats and divs in the regular document flow fixed the problem. The enclosed patch fixes it, works properly and looks acceptable in all the browsers I've tested (IE6, Opera/win, Safari and FF on OS/X). The only known issue with it is that the clickmask that made the entire row clickable is gone. I don't consider that a major drawback because I have some unconfirmed reports that the clickmask interferes with the UI in some browsers.

comment:2 tellyworth6 years ago

  • Keywords has-patch added

comment:3 tellyworth6 years ago

argh, the progress bar winds up in the wrong place and makes other things unclickable.

comment:4 tellyworth6 years ago

Turned up another bug trying to fix this: prepareMediaItem() in handlers.js creates duplicate progress clickmask divs. There are two progress clickmasks in each item in the gallery tab, three in each item in the media library tab.

tellyworth6 years ago

Fix the progress bar, remove some unnecessary markup

comment:5 tellyworth6 years ago

The new patch works well in IE6, Safari 3.1 and Firefox 2. The overlap issue in IE6 is fixed. Progress bars display in all three browsers. I haven't yet tested Opera.

There are some visual differences with 2.5.0 but I think they are acceptable. The clickmask is gone (but as noted above, I don't think that's a major issue - it caused some compatibility issues and didn't work on the Gallery or Choose File tabs). The markup and CSS is slightly simpler, and the duplicate progress divs have been removed If anyone can improve on it, please do.

comment:6 ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7676]) Fix IE6 overlap and remove unnecessary markup. Props tellyworth. fixes #6661 for 2.5

comment:7 ryan6 years ago

(In [7677]) Fix IE6 overlap and remove unnecessary markup. Props tellyworth. fixes #6661 for trunk

Note: See TracTickets for help on using tickets.