WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6670 closed defect (bug) (duplicate)

Creating, editing and managing links causes various Notices

Reported by: simonwheatley Owned by: westi
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords: needs-patch needs-testing
Focuses: Cc:

Description

Steps to reproduce:

  1. Define the constant WP_DEBUG in wp_config.php
  1. Add/edit/manage links in the admin area
  1. Check the PHP error log, and you should see:

Notice:Undefined index: added in /Users/simon/Projects/WordPress-2.5/site/wp-admin/link-add.php:21

Notice:Undefined property: stdClass::$link_description in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-link-form.php:95

Notice:Undefined property: stdClass::$link_target in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-link-form.php:142

Notice:Undefined property: stdClass::$link_target in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-link-form.php:145

Notice:Undefined property: stdClass::$link_rel in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-link-form.php:160

Notice:Undefined property: stdClass::$link_rel in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-link-form.php:17

Notice:Undefined property: stdClass::$link_image in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-link-form.php:273

Notice:Undefined property: stdClass::$link_rating in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-link-form.php:289

Notice:Undefined index: deletebookmarks in /Users/simon/Projects/WordPress-2.5/site/wp-admin/link.php:9

Notice:Undefined index: link_visible in /Users/simon/Projects/WordPress-2.5/site/wp-admin/includes/bookmark.php:16

Notice:Undefined index: link_owner in /Users/simon/Projects/WordPress-2.5/site/wp-includes/bookmark.php:250

Notice:Undefined index: link_name in /Users/simon/Projects/WordPress-2.5/site/wp-admin/link-add.php:21

Notice:Undefined index: s in /Users/simon/Projects/WordPress-2.5/site/wp-admin/link-manager.php:81

Notice:Undefined variable: i in /Users/simon/Projects/WordPress-2.5/site/wp-admin/link-manager.php:164

Attachments (1)

links.patch (7.7 KB) - added by simonwheatley 7 years ago.
Patch to reduce Notices when creating, editing and managing links

Download all attachments as: .zip

Change History (4)

@simonwheatley7 years ago

Patch to reduce Notices when creating, editing and managing links

comment:1 @westi7 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone changed from 2.5.1 to 2.6
  • Owner changed from anonymous to westi
  • Status changed from new to assigned

2.6 is a more appropriate target for these fixes.

Just adding @ is not the right fix.

comment:2 @jacobsantos7 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #6670

comment:3 @jacobsantos7 years ago

Duplicate of #6669

Note: See TracTickets for help on using tickets.