WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#6671 closed defect (bug) (duplicate)

Browsing the wp-admin manage screen causes various Notices

Reported by: simonwheatley Owned by: westi
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

Steps to reproduce:

  1. Define the constant WP_DEBUG in wp_config.php
  1. Click around the manage categories screen
  1. Check the PHP error log, and you should see:

Notice:Undefined index: s in /Users/simon/Projects/WordPress-2.5/site/wp-admin/categories.php:129
Notice:Undefined variable: category in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-category-form.php:15
Notice:Trying to get property of non-object in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-category-form.php:25
Notice:Trying to get property of non-object in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-category-form.php:30
Notice:Trying to get property of non-object in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-category-form.php:35
Notice:Trying to get property of non-object in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-category-form.php:41
Notice:Trying to get property of non-object in /Users/simon/Projects/WordPress-2.5/site/wp-admin/edit-category-form.php:47

Attachments (1)

manage_categories.patch (4.0 KB) - added by simonwheatley 7 years ago.
Patch to reduce the amount of Notices generated when on manage categories screen

Download all attachments as: .zip

Change History (3)

@simonwheatley7 years ago

Patch to reduce the amount of Notices generated when on manage categories screen

comment:1 @westi7 years ago

  • Keywords needs-patch added; has-patch needs-testing removed
  • Milestone changed from 2.5.1 to 2.6
  • Owner changed from anonymous to westi
  • Status changed from new to assigned

2.6 is a more appropriate target for these fixes.

Just adding @ is not the right fix.

comment:2 @jacobsantos7 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #6669

Note: See TracTickets for help on using tickets.