Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#6692 closed defect (bug) (duplicate)

Handling of errors in wp-login.php

Reported by: dtc Owned by: ryan
Milestone: Priority: high
Severity: normal Version: 2.5
Component: General Keywords: errors, wp-login
Focuses: Cc:



There has been some changes in the way errors are handled in wp-login.php : in WP 2.3.x, there was a global array defined ($errors[]) which could be interacted with via plugins :

$errors['user_email'] = __('<strong>ERROR</strong>: The email address
is not correct.');

With WP2.5, plugins can't seem to add to $errors->add(). I think I've
tried every possibility and I cannot make out why in a plugin
something like :

$errors->add('invalid_email', __('<strong>ERROR</strong>: The email
address is not correct.'));

does not work. I should say that it is part of a function that is inserted through add_action('register_post').

Add that line make wp-login.php go blank.

Change History (2)

comment:1 @ryan7 years ago

  • Owner changed from anonymous to ryan

comment:2 @ryan7 years ago

  • Milestone 2.5.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5763

Note: See TracTickets for help on using tickets.