WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#6711 closed defect (bug) (duplicate)

Closing "write post" window in 2.5 leads to popup asking if you want to navigate away from the page

Reported by: cyndin Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.5
Component: TinyMCE Keywords: needs-patch
Focuses: Cc:

Description

I found related tickets but nothing for 2.5 directly on point.

If I try to close the "write post" window, I get a popup asking:

"Are you sure you want to navigate away from this page?
The changes you made will be lost if you navigate away from this page.
Press okay to continue or cancel to stay on the current page."

This did not occur in WP 2.3. I use Mozilla on OS 10.2.8 on a Mac G4.

I got this error repeatedly even though I had not changed the page since last doing a manual save. It had been idle for hours. I am guessing that the auto-save reset it to be marked as edited.

As a test, I did another manual save and closed the window. It closed promptly without the popup warning.

This sounds like a useful feature that merely needs some tweaking to avoid false positives.

Thanks.

Change History (5)

comment:1 @Viper007Bond7 years ago

  • Component changed from General to TinyMCE

It's TinyMCE doing it and I'm 99% sure it did it in WordPress 2.3 if you had TinyMCE enabled.

comment:2 @janeforshort7 years ago

  • Milestone changed from 2.7 to 2.9

comment:3 @mrmist6 years ago

  • Keywords needs-patch added

Still a bug at rev 10285.

comment:4 @Denis-de-Bernardy6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

not a bug, a feature. if autosave gets triggered, it'll prompt. the real issue is that autosave and post revisions occur when no changes occur. See #8939 and #7392.

comment:5 @Denis-de-Bernardy6 years ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.