WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6713 closed defect (bug) (fixed)

swfupload: server response is truncated in some Flash versions

Reported by: tellyworth Owned by:
Milestone: 2.5.1 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: has-patch
Focuses: Cc:

Description

There is a bug in either swfupload or Flash itself that sometimes causes the server response from a file upload to be truncated in Linux and Mac OS:

http://code.google.com/p/swfupload/issues/detail?id=4&colspec=ID%20Type%20Status%20Summary%20FixReleasedIn%20FixTargetedFor

It appears only to happen on certain servers. I've been able to reproduce this using my MacBook - it fails on some WP installs but not others. I haven't been able to determine the cause (nor have the swfupload developers it appears) but I suspect it's a bug in the Flash Player's TCP/IP code.

The enclosed patch works around the problem by greatly reducing the size of the server response to a Flash file upload. Instead of returning a big chunk o html on success it returns the ID of the uploaded file. The html detail form for the file is then fetched in a second ajax request.

Attachments (1)

plan-b-r7641-2.patch (3.7 KB) - added by tellyworth 7 years ago.

Download all attachments as: .zip

Change History (3)

@tellyworth7 years ago

comment:1 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7682]) Workaround response truncation by reducing size of response after uploading with flash uploader. Props tellyworth. fixes #6713

comment:2 @ryan7 years ago

(In [7683]) Workaround response truncation by reducing size of response after uploading with flash uploader. Props tellyworth. fixes #6713 for 2.5

Note: See TracTickets for help on using tickets.