WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#6715 closed defect (bug) (worksforme)

Hitting publish button got error then going to HTML mode made post disappear entirely

Reported by: cyndin Owned by:
Milestone: Priority: normal
Severity: blocker Version: 2.5
Component: General Keywords:
Focuses: Cc:

Description

I wrote a new post (over several minutes, so the auto-save did its thing). I hit the publish button and got that popup that I get when trying to close a "write post" window about nagivating away from the page. (see http://trac.wordpress.org/ticket/6711 )

Of course I hit cancel. Then I was back in the post. Somehow, I got the idea to cut and paste all my text over to a word file, just in case. Then I decided to peek at the HTML code for the post.

The post disappeared! The HTML window came up but the text area was blank. The title and slug are intact, along with my tags and categories. But the text is gone. I went back to visual mode and the text is still missing.

I have checked my blog and the post did not publish. The post is listed as a draft, but the text is still missing (it's no longer blank though...the only thing there is a close-linebreak marker.

Trying this again...I pasted the text back into the draft. I fixed a couple of formatting things that were lost (took several tries; it messed with my code as a tried). I went into HTML mode; text was still there. Went back to Visual mode; text was still there.

I tried "publish" again and this time it worked.

What a terrifying bug! I've never lost a post before. In fact, the older versions of WP were so good that if my browser or computer crashed while I was in the middle of a post, even if I never hit "save," there would be a draft waiting for me with everything but the last couple of seconds.

Change History (3)

comment:1 cyndin6 years ago

  • Severity changed from critical to blocker

Please somebody make this a priority. It just happened again. I spent half an hour writing a post then clicked on "HTML" to clean up the code and the post disappeared!! I didn't have a saved copy this time. I can not believe this could happen. It never happened in older versions of WP.

You know how you get your first auto-save after you type the title then click on the body of the post? Well that's what it reverts to. The title is saved, along with the original slug (before my edit) and any other changes (category, author, tags) I made before putting in the title. Since I write the title first, there is no text. None.

I even went to the shell where my blog resides and searched for drafts. I don't know what else to do. Honestly, I'm practically in tears. This is so awful I want to switch blog software or at least go back to 2.3 (which was buggy but worked).

Do not tell me I should save my drafts manually. I never had to in 2.3 and earlier so I'm not used to it, and I didn't do anything, I just went to look at the HTML. Plus I have auto-save set to save every 2 minutes. And saving drafts puts you into a different window and you have to click on the edit post again to go back. There is no more "save and continue editing" like before. Someone on a WP board complained that that feature was gone and someone else laughed and said that's what the auto-save is for. Well, it's no good if it doesn't work.

This should not happen. Please fix this.

comment:2 cyndin6 years ago

Please also see: http://trac.wordpress.org/ticket/6757
Where I get the same disasterous bug when attempting a manual save.

comment:3 pishmishy6 years ago

  • Milestone 2.7 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

cyndin, I can't replicate this. If I try to publish a draft that's been autosaved once, but hasn't autosaved the last few words I've written, it publishes successfully with all the content. I'm going to close this ticket as worksforme. Please could you try downloading the latest version of WordPress and testing again.

Note: See TracTickets for help on using tickets.