WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6731 closed defect (bug) (fixed)

edit-pages.php does not correctly order pages by menu_order

Reported by: torfason Owned by:
Milestone: 2.5.1 Priority: normal
Severity: normal Version: 2.5
Component: Administration Keywords: edit-pages.php query.php
Focuses: Cc:

Description

In version 2.5, as well as in the most recent checkout, the list of pages generated by edit-pages.php does not correctly order pages by the menu_order column. The reason is the lack of a break statement in query.php, which causes the menu_order case to fall through to the next case and the $orderby variable gets set to $wpdb->posts.ID.

A patch detailing an insertion of this break statement is attached, which seems to fix the problem.

Attachments (1)

query-php-break-statement.diff (339 bytes) - added by torfason 7 years ago.
Patch to fix the bug, by inserting a break into the statement

Download all attachments as: .zip

Change History (5)

@torfason7 years ago

Patch to fix the bug, by inserting a break into the statement

comment:1 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7684]) Fix menu_order ordering. Props torfason. fixes #6731 for 2.5

comment:2 @ryan7 years ago

(In [7685]) Fix menu_order ordering. Props torfason. fixes #6731 for trunk

comment:3 @Viper007Bond7 years ago

Dupe of #6587 but since this one got the fix, I'll close the other one.

comment:4 @Viper007Bond7 years ago

  • Milestone changed from 2.7 to 2.5.1
  • Version set to 2.5
Note: See TracTickets for help on using tickets.