WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#6745 closed defect (bug) (worksforme)

2.5: white screen when inserting image in post

Reported by: windansea Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Upload Keywords: image, insert, inserting, white, screen, impossible,
Focuses: Cc:

Description

Hi,

I followed and tried all the suggestions 1-9 in the sticky 'image media uploader problem' forumtopic by 'Otto42'.

Only the final step is missing: I cannot insert the image in the post. The screen turns white and nothing happens (IE6 and Firefox/2.0.0.13. Seeing more posts about this problem, I'm no exception this time.

But what is missing is a fix, explanation or way to search to find the solution.

Thanks!

Change History (11)

comment:1 tellyworth6 years ago

Can you please post the exact steps to reproduce the problem? This only happens under specific circumstances and we don't know what they are yet.

comment:2 windansea6 years ago

Hi,

The exact circumstances are that I can upload the images, which are 'crunched' normally. Although I see in IE6 the uploaded images 'behind' the others when I click on show (the others do not get down). I'm logged in with 'administrator' rights. When I want to insert an image, nothing happens. The flash screen turns white and Internet Explore gives a (javascript?) error left lower corner:

line 12
char 3
Error: object doesn't support this property or method
Code: 0
URL: absolute url/wp-admin/post-new.php

What other details could be usefull?

Thanks

Bert

comment:3 pcorn546 years ago

  • Priority changed from normal to high
  • Version changed from 2.5 to 2.5.1

I am suddenly experiencing the same problems using 2.5.1 and Firefox.

Images upload normally, crunch and and are properly displayed.

Fill in the appropriate date, click "insert into post" and the white screen appears. In the lower left of the broweser is the word "Done". No javascript error showing in my case.

When I back out, everything is normal in the post except the absence of the image.

When I click to add an image, the previous images shows under Gallery, and is accessible by clicking "Show", however, the cycle repeats itself.

comment:4 dbaker6 years ago

I too started having this problem today (19th of May). I am hosted on Media Temple, perhaps we all are and they made a change someplace?

I can upload an image fine, it shoes up in folder (checked via FTP) and in Media Gallery. When I click "insert into post" the window goes white and FF says Done (I don't get java error either). The White window stays up until I click the close button and then the image is not in the post. My problem is exactly like pcorn54.

comment:5 dbaker6 years ago

  • Priority changed from high to normal

And the rabbit hole deepens...it works for me in IE7, although the popup window loads half off the bottom of the screen, it works. Strange. Does anyone else see a simalar result using IE7?

I removed and re-installed FF 2.0.0.14. It still doesnt work. I will try FF 3 BETA later and report back.

comment:6 dbaker6 years ago

Just tried it with FF BETA 3 RC2 and I get the same problem. Very strange.

It works in IE7, although the popup window is half off the bottom of the screen.

comment:7 DD326 years ago

  • Milestone set to 2.6

comment:8 thalveig6 years ago

Hello,

Same problem appearing here for one of my customer under FF 3 and Windows XP: can upload a media but screen goes white when trying to "insert into post".

Any clue/known fix?

Thanks

comment:9 mrmist5 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Closing this as worksforme. Re-open if this is still an issue in 2.7, or discuss it in the WordPress support forums.

comment:10 follow-up: benny1481485 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 2.5.1 to 2.7

I'm having this exact issue in WP 2.7. Using FF and IE, still no luck...

This just started happening, and I have not changed anything on my blog...no new plugins or anything of that nature.

I use the insert media/image icon, it shows to be "crunching" but when it's finished, there is a blank white screen where the image used to be with what looks to be a small icon of a paper torn in half. If I hit "insert into post" it inserts the same white image.

Any ideas how to fix?

comment:11 in reply to: ↑ 10 azaozz5 years ago

  • Component changed from TinyMCE to Upload
  • Resolution set to worksforme
  • Status changed from reopened to closed

Replying to benny148148:

I'm having this exact issue in WP 2.7...

This sounds like a support question better handled on the forum. The usual troubleshooting steps are: disable all plugins, switch to the default theme, clear browser cache and force-refresh the uploader iframe. Then monitor for any js and/or php errors and include them in your forum thread. Also check if the file has been uploaded and try using the "Browser uploader".

Note: See TracTickets for help on using tickets.