WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 19 months ago

Last modified 19 months ago

#6768 closed defect (bug) (worksforme)

Punctuation can break photo uploads

Reported by: flammable Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Upload Keywords:
Focuses: Cc:

Description

I'm doing a lot of photo uploads, and I came across a file I named 'Taking a picture of me?.JPG' - I'm using Mac OS X, so a filename containing a question mark is legal. I don't have Windows running right now, but I'm pretty sure it's disallowed there.

Anyway, I tried uploading this picture, and although the image uploader accepted it, and the progress bar completed, it never built a thumbnail for the picture (see attachment 1). The image is absent when viewing the gallery on a WordPress page, but when browsing the media library, it seems to know the item exists (see attachment 2). I blurred out my path information, because that's apparently a good idea.

Renaming the file to 'Taking a picture of me.JPG' allowed it to upload without any issues.

I'm using Safari 3.1.1 on Mac OS X 10.5.2. Am hosted with Dreamhost. Let me know if I can supply any more details. :)

Thanks!

Attachments (2)

Picture 1.png (59.2 KB) - added by flammable 7 years ago.
Picture 2.png (33.4 KB) - added by flammable 7 years ago.

Download all attachments as: .zip

Change History (8)

@flammable7 years ago

@flammable7 years ago

comment:1 @ryan7 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

comment:2 @Denis-de-Bernardy6 years ago

  • Component changed from General to Upload
  • Owner anonymous deleted

comment:3 @Denis-de-Bernardy6 years ago

confirmed in trunk. it's probably due to swfuploader. placing the following in async-upload.php reveals some information:

header('Content-Type: text/plain; charset=' . get_option('blog_charset'));
var_dump($_FILES);die;
/*
array(1) {
  ["async-upload"]=>
  array(5) {
    ["name"]=>
    string(4) "test" // should be test?.jpg
    ["type"]=>
    string(24) "application/octet-stream"
    ["tmp_name"]=>
    string(26) "/private/var/tmp/phpxbU53I"
    ["error"]=>
    int(0)
    ["size"]=>
    int(15243)
  }
}
*/

comment:4 @janeforshort5 years ago

  • Milestone changed from 2.9 to Future Release

Punting due to lack of time and traction.

comment:5 @iseulde19 months ago

  • Keywords gallery image uploader removed
  • Resolution set to worksforme
  • Status changed from new to closed

Tested in 3.6.

comment:6 @helen19 months ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.