WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#6790 closed defect (bug) (invalid)

HTML error

Reported by: nospam22 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

I am getting really annoyed at a coding bug in WP 2.5. If you place an image or some other object in your post and center it, all the text following automatically adds an align left html command which triggers validation errors. What that means is that every time I center something I have to go back through 2.5 and clean up the code. NOT FUN.

I am no coding expert so I have no idea what is causing this, but it was not present in 2.3. You can duplicate the error very easily by doing the same thing.

If I missed something I apologize, but long-time WP users should not have to go through ANY documentation to do something as elementary as posting.

Change History (1)

comment:1 azaozz6 years ago

  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Can't reproduce this. The only thing changed when clicking the "Align Center" button in the visual editor in 2.5 is style="text-align:center;" added to the surrounding <p> tag. That style is removed when clicking second time on the button while the image is selected.

Furthermore TinyMCE 3 doesn't use align="..." which is not XHTML 1.0 compliant, it always uses style="...".

This sounds like a problem with your particular installation. There are several threads in the support forum that describe how to troubleshoot it: disabling plugins, deleting and re-uploading the "tinymce" directory, deleting the file(s) in /wp-content/uploads/js-cache/, etc.

Closing as invalid for now, if it still happens after troubleshooting this installation, or if you reproduce it on another one (like the 2.6 demo at wp.chrisjohnston.org) feel free to reopen it.

Note: See TracTickets for help on using tickets.