WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6798 closed enhancement (duplicate)

When using a page as front page, is_home returns false

Reported by: RanYanivHartstein Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Template Keywords:
Focuses: Cc:

Description

When selecting "Front page displays a static page" on Reading options page, the is_home() function returns false when on the front page.

Change History (5)

comment:1 @Denis-de-Bernardy7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

it is supposed to. use is_front_page().

D.

comment:2 @Denis-de-Bernardy7 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Type changed from defect to enhancement
  • Version set to 2.5

maybe we could add an is_blog() template tag, to avoid user confusion though.

comment:3 @Denis-de-Bernardy7 years ago

adding to this one, when a plugin catches a permalink, would it be possible to reset the is_*() functions? now reading, for instance, will return true on is_home() when it catches /library

D.

comment:4 @ryan7 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Marking this as a duplicate of #3682. is_home() follows the page that shows the posts. is_front_page() is always the front page.

comment:5 @Nazgul7 years ago

  • Milestone 2.6 deleted
Note: See TracTickets for help on using tickets.