WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#6846 closed defect (bug) (duplicate)

upload media http error on password protected root wp folder

Reported by: michelwp Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.1
Component: General Keywords: upload 2nd-opinion needs-patch
Focuses: Cc:

Description

this defect was not present in former release (<=233):

when uploading media (png, jpg, ...) on a wp 2.5.x site installed in a password protected folder (.htacess/.htpasswd) : an http error occur !
(tested both with safari 3.1.1 and lastest Firefox on Mac.)

it is a loss that don't permit to prepare securely a site based on wp25...

Change History (4)

comment:1 follow-up: DD326 years ago

This would be due to the Flash uploader not supporting .htaccess password protection.

AFAIK, Unless there has been a change in the SwfUploader package, the only way currently is to disable the flash uploader via a plugin: http://trac.wordpress.org/attachment/ticket/6406/no-flash-uploader.php?format=raw

comment:2 in reply to: ↑ 1 michelwp6 years ago

Well, it is a short but efficient code. Why WP don't include this option in settings (like editor).

M.

Replying to DD32:

This would be due to the Flash uploader not supporting .htaccess password protection.

AFAIK, Unless there has been a change in the SwfUploader package, the only way currently is to disable the flash uploader via a plugin: http://trac.wordpress.org/attachment/ticket/6406/no-flash-uploader.php?format=raw

comment:3 DD326 years ago

  • Keywords 2nd-opinion needs-patch added
  • Milestone changed from 2.5.2 to 2.6

Well, it is a short but efficient code. Why WP don't include this option in settings (like editor).

I guess you'll just have to resd the #6406 ticket for that.

comment:4 DD325 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6473 (Wordpress 2.5 fails to allow file uploads if you use .htaccess to secure wp-admin)

Note: See TracTickets for help on using tickets.