Make WordPress Core

Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#6858 closed defect (bug) (worksforme)

Editing timestamp for "today" has order reversed somewhere.

Reported by: yaman666 Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.5.1
Component: Administration Keywords: timestamp
Focuses: Cc:


Just upgraded to wordpress 2.5.1, so not sure if this issue existed before.

I created a new post yesterday (26.04), set its timestamp to today (27.04) it was not posted, I assumed I had to wait until today.

Today I saw that it still wasn't posted and when I went to manage posts, it listed it as 11 hours from now, though it should have been 11 hours ago. I played around with timestamp and saw that it always adds, as if it is taking an absolute value instead of subtracting when timestamp is in the past.

I.e. right now is 12:48. When setting timestamp to 13:15 and looking at manage posts list, it says 27 minutes from now, so correct - 27 minutes in the future. However, when I set timestamp to 12:15 and go to manage posts it says 33 minutes from now instead of 33 minutes ago.

Attachments (1)

WordpressTimestampDoh.png (173.2 KB) - added by jeffreymcmanus 8 years ago.

Download all attachments as: .zip

Change History (5)

#1 @yaman666
8 years ago

After a little more testing I realized the problem is a little more complicated. Even as I set timestamp 2 minutes in the future and waited for 2 minutes, it rolled over and started counting up again without publishing the post!

The only way for me to publish that existing post was to set timestamp to yesterday's date or earlier.

So in order to have today's date I had to delete the post, create a new post, and press publish without touching timestamp.

#2 @jeffreymcmanus
8 years ago

I just ran across what I think is the same problem. I wrote a post and scheduled it for publishing 15 hours in the future, and the Manage Posts page says "15 hours ago". I've attached a screenie.

#3 @ryan
7 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

#4 @Denis-de-Bernardy
7 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

please re-open with feedback if this isn't fixed in 2.8 trunk

Note: See TracTickets for help on using tickets.