WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#6869 closed defect (bug) (duplicate)

Author loses image alignment - admin doesn't

Reported by: scvbruce Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

My authors are not able to save the alignment they apply to images in posts with the Insert/edit emage icon.

When "admin" edits the picture with the Insert/edit emage icon on the visual editor, the code looks like this:

<strong>Does Microsoft really need Yahoo?<img class="alignright" style="float: right; margin: 4px;" src="http://technology.newsbyte.com/wp-content/uploads/2008/04/dignanperlow.jpg" alt="Dignan and Perlow" width="300" height="172" /></strong>


When an "author" edits the picture with the Insert/edit emage icon on the visual editor, and then saves the picture, the code looks like this, and the alignment goes away:

<strong>Does Microsoft really need Yahoo?<img class="alignright" style="4px;" src="http://technology.newsbyte.com/wp-content/uploads/2008/04/dignanperlow.jpg" alt="Dignan and Perlow" width="300" height="172" /></strong>

It's like an author doesn't have the permission to change that part of the code.

Change History (1)

comment:1 ionfish6 years ago

  • Milestone 2.7 deleted
  • Priority changed from high to normal
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed

Duplicate of #6868.

Note: See TracTickets for help on using tickets.