WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6876 closed defect (bug) (fixed)

Widgets do not drop in the correct place.

Reported by: KirkM Owned by: azaozz
Milestone: 2.6 Priority: high
Severity: normal Version: 2.5.1
Component: General Keywords: has-patch
Focuses: Cc:

Description

IN WP 2.5.1 I noticed that although I can drag an existing
sidebar widget up and down the column of existing ("existing" meaning
already assigned to my sidebar) widgets and the other widgets "make room"
properly, once I drop the widget I'm dragging it ends up on some other
random placement upon the page and not where I dropped it. "Saving Changes"
shows that the errant widget indeed had "dropped" into the proper slot even
though it had ended up "dropping" somewhere below the "Save Changes" button or somewhere else when I initially dropped it. In fact, I can just about drop an existing widget anywhere on the page besides the existing column of widgets and it just stays there. This is going to make for a sour upgrade experience seeing as how widgets are a highly used item for most folks

I originally posted on "wp-testers" and Ryan confirmed the problem but I haven't seen a ticket for this yet so I took the honor.

Attachments (1)

widgets-arrangement.patch (5.9 KB) - added by azaozz 12 years ago.

Download all attachments as: .zip

Change History (7)

#1 @ryan
12 years ago

  • Owner changed from anonymous to azaozz

Caused by fix for #6792. Fix is in the works.

#2 @azaozz
12 years ago

  • Keywords has-patch added

Fixes widgets arrangement and keeps the fix for wide widgets in IE.

#3 @ryan
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7881]) Widget arrangement fix from azaozz. fixes #6876 for trunk

#4 @ryan
12 years ago

(In [7882]) Widget arrangement fix from azaozz. fixes #6876 for 2.5

#5 @ryan
12 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

#6 @westi
12 years ago

  • Milestone changed from 2.9 to 2.6
Note: See TracTickets for help on using tickets.