WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#6896 closed defect (bug) (worksforme)

Wordpress Classic lacks CSS used by image uploader

Reported by: Hinrik Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Template Keywords: css
Focuses: Cc:

Description

The Wordpress Classic theme's style.css has no CSS for images, so when you upload an image and choose "alight right" for example, it won't.

Coyping the relevant sections (starts at "/* Begin Images */") from Wordpress Default's style.css fixes the problem.

Attachments (1)

style.css.diff (669 bytes) - added by JohnLamansky 6 years ago.
Adds image CSS from Default theme to the Classic theme

Download all attachments as: .zip

Change History (6)

comment:1 JohnLamansky6 years ago

  • Component changed from General to Template
  • Keywords has-patch needs-testing 2nd-opinion css added
  • Summary changed from Wordpress Classic has no CSS for images to Wordpress Classic lacks CSS used by image uploader

I've attached a patch. We need someone to:

  • Confirm that this is a problem on a default WP install
  • If so, test the patch suggested by the reporter to see if the problem is fixed

JohnLamansky6 years ago

Adds image CSS from Default theme to the Classic theme

comment:2 JohnLamansky6 years ago

  • Priority changed from normal to high

comment:3 ryan6 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

comment:4 mrmist6 years ago

Classic 1.5 as with WP 2.6 does have the align css so this is not a bug any more.

Tested uploaded image with align-right on both classic and default with a stock 2.6 install.

comment:5 mrmist5 years ago

  • Keywords has-patch needs-testing 2nd-opinion removed
  • Milestone 2.9 deleted
  • Priority changed from high to normal
  • Resolution set to worksforme
  • Status changed from new to closed

I reckon the classic template includes the necessary CSS to support the image uploader functions. Tested stock 2.7 with centre and right align options and a caption, under classic theme.

Note: See TracTickets for help on using tickets.