WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6905 closed defect (bug) (invalid)

Feeds always display full text

Reported by: gnot Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Regardless of the following option:

Settings->Reading->For each article in a feed, show 1) Full Text 2) Summary

and regardless of the existence of the <!--more--> within the post, the feeds always contain the full text.

This was noticed after performing the upgrade: 2.5->2.5.1

Have not tested with a clean 2.5.1 installation.

Attachments (1)

6905.diff (611 bytes) - added by DD32 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 DD326 years ago

and regardless of the existence of the <!--more--> within the post

Just a quick note: The use of <!--more--> will no longer split he post in a feed: See #6680

comment:2 gnot6 years ago

I was hoping that this particular bug would not be a feature...
Thanks

comment:3 DD326 years ago

What feed are you refering to specifically?
RSS, RSS2, or the Atom feed?

It appears that the RSS feed *allways* returns a summary feed.

The RSS2 feed however returns a Summary or a Full feed depending on the options set.

Patch attached to display a full length post in the RSS 0.92 feed.

DD326 years ago

comment:4 gnot6 years ago

Yes, I am aware of the RSS 0.92 feed always returning the summary.

I was referring to RSS 1.0 (RDF), RSS 2.0 and Atom 1.0 feeds. I changed the setting in order to deliver only summaries, but the three aforementioned feeds still deliver full text. When I find some time I will try with a clean installation.

PS: Thanks for that patch.

comment:5 follow-up: DD326 years ago

Marked #6922 as duplicate of this.

comment:6 in reply to: ↑ 5 DD326 years ago

Replying to DD32:

Marked #6922 as duplicate of this.

Should've mentioned, It does include a fix, However, I'm not sure about it:

From line 41, wp-includes/feed-rss2.php:

<?php if (get_option('rss_use_excerpt')) : ?>
                <description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
<?php else : ?>
                <description><![CDATA[<?php the_excerpt_rss() ?>]]></description>

changing the latter to the_content_rss() does give the description element the full post. However, The <content:encoded> element also contains the full post allready?

comment:7 Otto426 years ago

  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 2.5.1 deleted

This is not a bug, this is by design, and I really wish people would search first, as this has been explained a thousand times before.

The <description> contains the summary, always. What the "full text" does is to control whether or not the feed also contains a <content:encoded> with the full text. We do it this way because all feed readers understand it correctly and use the two fields for different things.

Yes, Firefox displays the description field and so it looks abbreviated. But Firefox is not a feed reader and not our target for feeds.

comment:8 gnot6 years ago

I have just released a small plugin (More-Feed-Excerpt to revert the behaviour back to what we have been used to. I believe it is complete and in accordance to the WordPress philosophy.

Note: See TracTickets for help on using tickets.