WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 10 days ago

#6976 closed defect (bug) (duplicate)

Warning from uninitalized index args in taxonomy.php wp_get_object_terms

Reported by: minddog Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.1
Component: General Keywords:
Focuses: Cc:

Description

To reproduce the issue, turn on debug mode and do a base installation of wordpress. To resolve this issue of only using args property of a taxonomy object is to check to see if $taxonomy->args has been set before using. The patch attached adds an isset() to the start of an if-statement to let the operation continue and to remove the warning from happening.

Attachments (1)

6976_fix.patch (645 bytes) - added by minddog 7 years ago.

Download all attachments as: .zip

Change History (4)

@minddog7 years ago

comment:1 @minddog7 years ago

This is the PHP notice, line #'s may differ:
Notice: Undefined property: stdClass::$args in <removed>/wp-includes/taxonomy.php on line 1061

comment:2 @kaspars4047 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket:6960

comment:3 @DrewAPicture10 days ago

  • Milestone 2.6 deleted
Note: See TracTickets for help on using tickets.