#6986 closed defect (bug) (fixed)
Plugin Automatic Update via FTP - SLL option will not deactivate once activated
| Reported by: | carltonbale | Owned by: | |
|---|---|---|---|
| Priority: | normal | Milestone: | 2.6 |
| Component: | Administration | Version: | 2.5.1 |
| Severity: | normal | Keywords: | plugin automatic upgrade FTP SSL has-patch commit |
| Cc: | Focuses: |
Description
In WordPress 2.5.0 and 2.5.1, plugin automatic update was working properly via FTP. I then decided to try the FTP SSL option and received the error message
"Error: There was an error connecting to the server, Please verify the settings are correct."
So apparently my server does not support FTP over SSL. So I disabled the SSL option by setting "Use SSL" to "No". However, I continued to receive the same connection error message as above. The message would appear no matter what was entered into the FTP configuration page.
I finally added the following line to my wp-config.php file:
define('FTP_SSL', false);
This caused the SSL setting within the plugin FTP updater to be overwritten with the correct value. FTP updates of plugins began to again function properly after making this change.
![(please configure the [header_logo] section in trac.ini)](/chrome/site/your_project_logo.png)
This is due to a rather anoying thing with PHP: