WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#6994 closed defect (bug) (worksforme)

Post content lost when saving

Reported by: synapsestudios Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.1
Component: General Keywords:
Focuses: Cc:

Description

When trying to write a post in the visual editor, after publishing it only some of text is actually saved and the rest is lost. The only way I have found to publish is to write it in the html tab and then publish that. After it has been saved, I can go back and edit it in the visual tab to include links, etc.

I use FF 2.0.0.14. The problem has happened for other posters to my blog as well.

I previously had used a plugin called instantupgrade to upgrade from 2.5.0 to 2.5.1 and thought it might have been to blame so I manually downloaded the latest tar to my server and copied over the wp-content dir and my wp-config file.

I deactivated all my plugins to confirm there was no conflict from them. Still having the issue. The content isn't just what was saved from before the auto-save (I wrote 2 paragraphs, and after the auto-save added more text to the first before publishing, that extra bit added to the 1st after the auto-save was there but the end of my 2nd paragraph, written before the auto-save was missing).

Possibly related is that the first auto save takes forever (aka >20 seconds to finally save). Let me know if more information is required, this is a huge problem for me and would love to find a solution ASAP.

Change History (7)

comment:1 synapsestudios6 years ago

Testing in IE confirms that this problem appears to be localized to FF. The auto save is much quicker in IE and the post was not truncated at all.

comment:2 synapsestudios6 years ago

  • Priority changed from high to highest omg bbq
  • Severity changed from critical to blocker

Check that last comment, I just got it to replicate in IE.
Possible other causes: I edit the post of another author and *poof* all but the first 100 or so characters of the post are gone after saving.

This is horribly frustrating and I would appreciate someone telling me that I am not insane and that this problem has been identified on other blogs...

comment:3 lloydbudd6 years ago

  • Milestone set to 2.7
  • Priority changed from highest omg bbq to normal
  • Severity changed from blocker to normal

Thank you for participating in WordPress! Please leave the Priority and Severity to be set by the development team.

Have you disabled all of your plugins and see if the issue still occurs? If it does there is something about your host or network connection or PC that needs to be isolated to identify what area to investigate next.

comment:4 synapsestudios6 years ago

From the originally submitted description: "I deactivated all my plugins to confirm there was no conflict from them. Still having the issue."

This has occurred for my other blog authors on their computers as well so I doubt that it is PC-related. It has also occurred on both IE and FF so I doubt that it is browser-related. It has occurred when editing the blog from the office and home as well. I run other WP blogs on the server and none of them have had this problem.

Also on a side note, if you don't want standard users to be able to modify the severity and/or priority then why even make those options available to me?

comment:5 synapsestudios6 years ago

I believe I have pinpointed the cause of this problem. In Settings -> Reading, we had changed the "encoding for pages and feeds" from UTF-8 to ISO-8859-1. Further searching after identifying this problem turned up another topic of the same nature for an older WP version: http://wordpress.org/support/topic/150649

Hopefully this helps to resolve the issue in WP soon.

comment:6 matt6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

unable to duplicate.

comment:7 thee175 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.