WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6997 closed defect (bug) (duplicate)

Cannot use year (ie, 2008) in page slug

Reported by: chrismou Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.1
Component: General Keywords: needs-patch
Focuses: Cc:

Description

WordPress doesn't seem to like the idea of me using "2008" or "2007" as a page slug.

The situation is that I'm writing a page a year dedicated to a festival I go to. The front page is located at mou.me.uk/glastonbury, and sections for each year would be located at mou.me.uk/glastonbury/2007/ and mou.me.uk/glastonbury/2008/ respectively.

BUT, when I try and view either of these pages, it shows me the page located at mou.me.uk/glastonbury - ie, the parent page.

Bizarrely, when I entered mou.me.uk/glastonbury/2007/a/ (just to test), it redirected me to a post I wrote in 2007.

I assume that this is not intended behaviour? I can see the logic in trying to extract a date from the URL and find the closest matching post, but surely this should be overridden if Ive created a page where the slug matches exactly whats in the address bar?

Change History (3)

#1 @DD32
12 years ago

  • Keywords needs-patch added

#2 @Otto42
12 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

#3 @thee17
12 years ago

  • Milestone 2.6 deleted
Note: See TracTickets for help on using tickets.