WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#7009 closed defect (bug) (invalid)

Invalid XHTML Produced by Comments

Reported by: singpolyma Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Formatting Keywords:
Focuses: Cc:

Description

If you look at http://singpolyma.net/plugins/actionstream/#comment-67645 you will see that a <p> tag is opening before a <code> tag - and then closing *inside* the <code> tag - clearly in violation of XHTML (or even HTML4) specs. There is a similar problem near the </code>. These <p> blocks are being generated by WordPress (the <code> tags were entered by the user), so it seems to be a bug.

Change History (11)

comment:1 @DD327 years ago

  • Milestone set to 2.6
  • Version set to 2.5

comment:2 @mrmist6 years ago

  • Keywords needs-patch added
  • Milestone changed from 2.9 to 2.8
  • Priority changed from high to normal
  • Severity changed from major to normal
  • Version changed from 2.5 to 2.7

Still reproducable.

comment:3 @ryan6 years ago

  • Component changed from General to Comments
  • Owner anonymous deleted

comment:4 @Denis-de-Bernardy6 years ago

  • Milestone changed from 2.8 to Future Release

comment:5 @Denis-de-Bernardy6 years ago

there is a balanceTags call on pre_comment_content. shouldn't this deal with it, or is it really a balanceTags bug?

comment:6 @Denis-de-Bernardy6 years ago

  • Component changed from Comments to Formatting
  • Milestone changed from Future Release to 2.9

comment:7 @dwright6 years ago

  • Cc david_v_wright@… added

I can not reproduce this issue.

how did you reproduce this issue?

the site in question appears fine to me.

<p><code><br>
Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 1: parser error : Start tag expected, '&lt;' not found in /var/www/vhosts/dev.boldlygoing.com/httpdocs/wp-content/plugins/wp-diso-actionstream/actionstream.php on line 323</code></p>

comment:8 @ryan6 years ago

  • Milestone changed from 2.9 to Future Release

comment:9 @solarissmoke4 years ago

  • Keywords close added; needs-patch removed

Can't reproduce - and the HTML in the link provided looks fine as dwright says.

comment:10 @solarissmoke4 years ago

  • Keywords close removed
  • Resolution set to invalid
  • Status changed from new to closed

No feedback on how to reproduce.

comment:11 @ocean904 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.