WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7027 closed defect (bug) (fixed)

Admin removed from authors list and logged in as author

Reported by: paix120 Owned by:
Milestone: 2.7 Priority: high
Severity: major Version: 2.5.1
Component: Administration Keywords: author, admin, administrator, post
Focuses: Cc:

Description

After logging in as an administrator and adding other authors, new admin posts then show up with another user as the author, and administrator no longer shows up in "Post Author" dropdown:
http://wordpress.org/support/topic/169422?replies=6#post-765588

Change History (10)

comment:1 @johnbillion7 years ago

Confirming this bug.

Currently trying to find the exact steps needed to reproduce.

comment:2 @pampfelimetten7 years ago

Can confirm too, although I don't know how to reproduce.
If more infos about my config are needed, please tell me (e.g. sql tables)

comment:3 follow-up: @thee177 years ago

I thought this was a glitch, I creadted an new admin, deleted and recreated and works of now.

comment:4 in reply to: ↑ 3 @keppy7 years ago

Replying to thee17:

I thought this was a glitch, I creadted an new admin, deleted and recreated and works of now.

I believe this is another occurrence of this bug popping back up: http://trac.wordpress.org/ticket/2818

The fix for that ticket (creating another admin, changing original admin to an editor, saving and then changing admin back to an administrator) should work. But the wp_user_level missing for admin seems to be the root cause again.

comment:5 @DD327 years ago

Does anyone have any steps to reproduce? I've tried, and simply cant get it to happen?

comment:7 @westi7 years ago

Not sure exactly what is going on here.

I can get a blank line if i nuke the display_name in phpmyadmin but we really need a db dump to reproduce this I suspect.

comment:8 @westi7 years ago

(In [9344]) Make sure we always display something in the dropdown. See #7027.

comment:9 @westi7 years ago

That may improve things..

comment:10 @markjaquith7 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.