WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#7028 closed defect (bug) (duplicate)

Formatting lost when doing install.php

Reported by: MichaelH Owned by:
Milestone: Priority: high
Severity: normal Version: 2.6
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

With 2.6-bleeding2 (R7986) and doing install.php, the install screen has lost most formatting. Installation does progress successfully though.

Install screen at 2.6 bleeding2 R7986

Attachments (1)

fix_no-style_install.diff (528 bytes) - added by Potter_System 13 years ago.
Patch for #7028

Download all attachments as: .zip

Change History (5)

#1 @Viper007Bond
13 years ago

  • Keywords needs-patch added
  • Priority changed from normal to high

Confirmed. It's due to the new style loader. The path it has is /wp-admin/css/install.css.

#2 @Potter_System
13 years ago

  • Keywords has-patch added; needs-patch removed

It seems get_option('siteurl') doesn't work when installing. Therefore, $wp_styles->base_url is NIL, and raw value from wp_default_styles is shown.

I've added a conditional in base_url from function wp_default_styles, building a path in a almost-kamikaze way or pull the value from get_option('siteurl') whether WP_INSTALLING is true or false.

It worked flawlessly, but it may become a bit dangerous

#3 @sambauers
13 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

More complete fix at #7129

Closing as duplicate (even though this came first).

#4 @thee17
13 years ago

  • Milestone 2.6 deleted
Note: See TracTickets for help on using tickets.