WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7046 closed defect (bug) (invalid)

non visual editor inserting unwanted code

Reported by: newfoundnoise82 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

On pages (it only has occurred on pages) using the non visual editor I am consistently getting break tags and paragraph tags thrown in by wordpress.

When inserting a tag that is not a block level element wordpress will insert this code so instead of:

<span>
Hello World!
</span>

It would spit out:

<span><br/>
Hello World!
</span>

Or possibly even:

<p><span><br/>
Hello World!
</span></p>

I communicated over twitter with a person at automattic who told me to come here and submit a bug report so here I am.

I have tried re-installing wordpress and various other random css tricks to no avail, so I am turning to the wordpress community.

The errors can be seen on the following pages: http://www.cadistrict38.org/front and http://www.cadistrict38.org/staff although some css or comments are utilized to get a somewhat acceptable look while this issue is addressed.

Change History (3)

comment:1 azaozz6 years ago

When using the HTML editor in WordPress, each new line is usually converted to <br /> and two new lines to <p>. The tags are not shown to keep the text more readable. Typing:

<span>
Hello World!
</span>

is different than typing:

<span>Hello World!</span>

Of course, bot of these will have to be wrapped in <p> tags, so the html is compliant with the XHTML 1.0 specification.

The end result on the site should look like this:

<p><span>Hello World!</span></p>
<p>Some other text...</p>

comment:2 mattyrob6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

No traction on this one for 5 months. Entry above intimates this is not a bug - closing ticket

comment:3 jacobsantos6 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.