Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#7047 closed defect (bug) (worksforme)

Saving post generates errors

Reported by: zenopopovici Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.1
Component: Administration Keywords: array, foreach, posting
Focuses: Cc:


On certain configurations saving post generates errors:

Warning: Invalid argument supplied for foreach() in /home/zeno/public_html/wp-admin/includes/post.php on line 227

Warning: array_search() [function.array-search]: Wrong datatype for second argument in /home/zeno/public_html/wp-admin/includes/post.php on line 326

Warning: Illegal string offset: -1211911650 in /home/zeno/public_html/wp-admin/includes/post.php on line 333

Warning: Cannot modify header information - headers already sent by (output started at /home/zeno/public_html/wp-admin/includes/post.php:227) in /home/zeno/public_html/wp-includes/classes.php on line 788

I belive arrays are improperly handled.
I've attached a fix.

Attachments (1)

save.diff (942 bytes) - added by zenopopovici 7 years ago.

Download all attachments as: .zip

Change History (3)

7 years ago

#1 @ryan
7 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

#2 @mrmist
7 years ago

  • Milestone 2.9 deleted
  • Priority changed from high to normal
  • Resolution set to worksforme
  • Severity changed from critical to normal
  • Status changed from new to closed

Closing as worksforme. We've gone through 2.7 since this and I can't reproduce it on IIS or Apache.

Note: See TracTickets for help on using tickets.