WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 14 months ago

#7051 closed enhancement (fixed)

Delete blacklisted comments rather than mark them as spam

Reported by: donncha Owned by: helen
Milestone: 4.4 Priority: normal
Severity: normal Version: 2.5.1
Component: Comments Keywords: has-patch
Focuses: Cc:

Description

Comments that are blacklisted because of the Blacklist keys on options-discussion.php should be deleted immediately instead of being marked as spam. Patch attached.

Attachments (5)

comment.diff (1.1 KB) - added by donncha 9 years ago.
Patch for wp-includes/comment.php
7051.diff (1.6 KB) - added by solarissmoke 6 years ago.
Place blacklisted comments in the trash
7051.2.diff (1.7 KB) - added by MikeHansenMe 22 months ago.
Refreshed
7051.3.diff (419 bytes) - added by wonderboymusic 15 months ago.
7051.4.diff (1.5 KB) - added by wonderboymusic 15 months ago.

Download all attachments as: .zip

Change History (28)

@donncha
9 years ago

Patch for wp-includes/comment.php

#1 @mdawaffe
9 years ago

This seems like a pretty big change. Can you say why blacklist matching comments should be deleted?

I have "casino" in my blacklist, but if I ever write a post about going to Vegas, I don't want all the comments to get deleted.

#2 @Viper007Bond
9 years ago

Yeah, I think spam is best. Allows for recovery.

#3 @donncha
9 years ago

This is something Photomatt and Markr wanted. Markr brought it up in conversation with a blogger who is getting lots of stupid comments from one particular user. He added that person's email address or IP into the blacklist expecting the comments to be deleted but instead he had to read the comments in the Akismet spam page and delete them.

They weren't submitted to Akismet so the spam page is probably the wrong page for these comments to be left in.

This is a result of confusion over what the blacklist does. Is it a spam list or stupid list? :)

#4 @Viper007Bond
9 years ago

Perhaps a new status is in order or something.

It just seems like not having them be instantly deleted would be a good idea incase there was a false positive as mdawaffe mentioned (Vegas).

#5 @ryan
8 years ago

  • Milestone changed from 2.5.2 to 2.9

Milestone 2.5.2 deleted

#6 @Denis-de-Bernardy
8 years ago

  • Component changed from General to Comments
  • Owner anonymous deleted

#7 @Denis-de-Bernardy
7 years ago

  • Keywords needs-patch close added; has-patch removed
  • Milestone changed from 2.9 to Future Release
  • Type changed from defect (bug) to enhancement

suggesting wontfix, personally.

#8 @solarissmoke
6 years ago

  • Keywords needs-patch removed

#9 follow-up: @nacin
6 years ago

Perhaps now that we have Trash, that could be where they end up?

#10 in reply to: ↑ 9 @Viper007Bond
6 years ago

Replying to nacin:

Perhaps now that we have Trash, that could be where they end up?

Strong +1

Allows recovery still and is a better fit. The comments from people on the blacklist aren't necessarily spam, they're just unwanted comments.

@solarissmoke
6 years ago

Place blacklisted comments in the trash

#11 @solarissmoke
6 years ago

  • Keywords has-patch added; close removed

#12 @chriscct7
2 years ago

  • Keywords dev-feedback added

Does someone from core want to quickly review the idea?
Essentially, blacklisted comments are moved to spam instead of trash. Its a simple 2 line patch file, so the only major thing really on this is whether or not blacklisted comments should go to trash or spam (where they currently go). I'm in favor of trash, as blacklisted comments can be non-spam, and they can be unintentionally flagged on the blacklist, but many users might think of all the comments in spam are spam and simply empty the spam folder without thinking.

@MikeHansenMe
22 months ago

Refreshed

#13 @MikeHansenMe
22 months ago

I think this makes good sense. Easy patch as well. I do see it causing any issues.

#14 @helen
22 months ago

What happens when somebody disables trash?

#15 @MikeHansenMe
22 months ago

If they are being set to trash and the trash is disabled they would be auto deleted. I am not sure if this is something we should account for or expected behavior.

#16 follow-up: @helen
22 months ago

Seems like it would be bad if comments started getting auto-deleted now, just because of the destructive/unrecoverable change in behavior.

#17 in reply to: ↑ 16 ; follow-up: @Denis-de-Bernardy
22 months ago

Replying to helen:

Seems like it would be bad if comments started getting auto-deleted now, just because of the destructive/unrecoverable change in behavior.

If someone bothers to disable the trash, wouldn't you agree that this person actually wants that destructive / unrecoverable behavior?

#18 in reply to: ↑ 17 ; follow-up: @helen
22 months ago

Replying to Denis-de-Bernardy:

If someone bothers to disable the trash, wouldn't you agree that this person actually wants that destructive / unrecoverable behavior?

I would not expect an upgrade of WordPress to suddenly cause blacklisted comments to be outright deleted rather than in some moderated state where I could recover them if I wanted to.

#19 in reply to: ↑ 18 @Denis-de-Bernardy
22 months ago

Replying to helen:

I would not expect an upgrade of WordPress to suddenly cause blacklisted comments to be outright deleted rather than in some moderated state where I could recover them if I wanted to.

I'll let you do what's right then:

https://core.trac.wordpress.org/ticket/7051#comment:7

#20 @helen
22 months ago

Stepping back a little further to look at the wider view, would it perhaps make more sense to note in comment meta that the comment is in spam because of the blacklist? If it does, then I think we can close this (as documentation that we've had this discussion) and make a new ticket.

#21 @wonderboymusic
15 months ago

  • Keywords dev-feedback removed
  • Milestone changed from Future Release to 4.4
  • Owner set to wonderboymusic
  • Status changed from new to assigned

#22 @wonderboymusic
14 months ago

  • Owner changed from wonderboymusic to helen
  • Status changed from assigned to reviewing

7051.4.diff - I really don't care what we do here

#23 @helen
14 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 34726:

Comments: Trash blacklisted comments by default.

If trash is disabled, they wil continue to go into spam like they do now.

props wonderboymusic, solarissmoke, MikeHansenMe.
fixes #7051.

Note: See TracTickets for help on using tickets.